patch from upstream for prompting problem when no tty associated with sudo
authorBdale Garbee <bdale@gag.com>
Thu, 7 Oct 2010 21:54:06 +0000 (15:54 -0600)
committerBdale Garbee <bdale@gag.com>
Thu, 7 Oct 2010 21:54:06 +0000 (15:54 -0600)
check.c
debian/changelog

diff --git a/check.c b/check.c
index d6efa6d0befe153b9d8dcb251fda09371bbf538e..afb6c2267dd9912cb127497e973cb790f4deff78 100644 (file)
--- a/check.c
+++ b/check.c
@@ -205,7 +205,7 @@ update_timestamp(timestampdir, timestampfile)
     char *timestampfile;
 {
     /* If using tty timestamps but we have no tty there is nothing to do. */
-    if (timestampfile && !user_ttypath)
+    if (def_tty_tickets && !user_ttypath)
        return;
 
     if (timestamp_uid != 0)
@@ -528,7 +528,7 @@ timestamp_status(timestampdir, timestampfile, user, flags)
     if (timestampfile && status != TS_ERROR) {
        if (status != TS_MISSING)
            status = TS_NOFILE;                 /* dir there, file missing */
-       if (!user_ttypath)
+       if (def_tty_tickets && !user_ttypath)
            goto done;                          /* no tty, always prompt */
        if (lstat(timestampfile, &sb) == 0) {
            if (!S_ISREG(sb.st_mode)) {
index 51eebde287a29657527ea879766987b71449a604..687948b5101ee6d41ae566a662dce730ad9613e8 100644 (file)
@@ -1,3 +1,12 @@
+sudo (1.7.4p4-4) unstable; urgency=low
+
+  * patch from upstream to resolve problem always prompting for a password
+    when run without a tty, closes: #599376
+  * change path syntax to avoid tar error when /var/run/sudo exists but is
+    empty, closes: #598877
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 21 Sep 2010 23:53:08 -0600
+
 sudo (1.7.4p4-3) unstable; urgency=low
 
   * make postinst clause for handling /var/run -> /var/lib transition less