try using explicit path to resolve ambiguous use of '..' in make targets
authorBdale Garbee <bdale@gag.com>
Tue, 7 Sep 2010 16:41:58 +0000 (10:41 -0600)
committerBdale Garbee <bdale@gag.com>
Tue, 7 Sep 2010 16:41:58 +0000 (10:41 -0600)
debian/rules

index 1ece390055b63badfbe3f00f8558463f17b2cf9e..41ea1fd0d87d4dafa6eb161eaee9f7371e6892cb 100755 (executable)
@@ -16,7 +16,7 @@ configure-stamp:
 
        # simple version
        mkdir -p build-simple
-       cd build-simple && NROFFPROG=/usr/bin/nroff ../configure \
+       cd build-simple && NROFFPROG=/usr/bin/nroff $(CURDIR)/configure \
                --prefix=/usr -v \
                --with-all-insults \
                --with-devel \
@@ -39,7 +39,7 @@ configure-stamp:
 
        # LDAP version
        mkdir -p build-ldap
-       cd build-ldap && NROFFPROG=/usr/bin/nroff ../configure \
+       cd build-ldap && NROFFPROG=/usr/bin/nroff $(CURDIR)/configure \
                --prefix=/usr -v \
                --with-all-insults \
                --with-devel \