patch to fix segfaults on hurd
authorBdale Garbee <bdale@gag.com>
Wed, 16 May 2012 17:28:45 +0000 (11:28 -0600)
committerBdale Garbee <bdale@gag.com>
Wed, 16 May 2012 17:28:45 +0000 (11:28 -0600)
debian/changelog
debian/patches/skip-noedit.diff [new file with mode: 0644]

index a03859874a5d54549bd06558e20ef7f7f665c93a..fe7d070e9385fac2a2a652500cf071f1b0ae800f 100644 (file)
@@ -2,6 +2,7 @@ sudo (1.8.5-1) UNRELEASED; urgency=low
 
   * new upstream version
   * patch to use flock on hurd, run autoconf in rules, closes: #655883
+  * patch to avoid calling unlink with null pointer on hurd, closes: #655948
   * patch to actually use hardening build flags, closes: #655417
   * fix sudo-ldap.postinst syntax issue, closes: #669576
 
diff --git a/debian/patches/skip-noedit.diff b/debian/patches/skip-noedit.diff
new file mode 100644 (file)
index 0000000..569bc13
--- /dev/null
@@ -0,0 +1,12 @@
+Skip installing/unlinking files without doedit set
+--- a/plugins/sudoers/visudo.c
++++ b/plugins/sudoers/visudo.c
+@@ -247,6 +247,8 @@
+     /* Install the sudoers temp files. */
+     tq_foreach_fwd(&sudoerslist, sp) {
++      if (!sp->doedit)
++          continue;
+       if (!sp->modified)
+           (void) unlink(sp->tpath);
+       else