Imported Upstream version 1.7.2p1 upstream/1.7.2p1
authorBdale Garbee <bdale@gag.com>
Mon, 31 Aug 2009 18:13:38 +0000 (12:13 -0600)
committerBdale Garbee <bdale@gag.com>
Mon, 31 Aug 2009 18:13:38 +0000 (12:13 -0600)
14 files changed:
ChangeLog
configure
configure.in
mkdefaults
sudo.cat
sudo.man.in
sudoers.cat
sudoers.ldap.cat
sudoers.ldap.man.in
sudoers.man.in
toke.c
toke.l
visudo.cat
visudo.man.in

index 5c61070320939558f7389324e6ff2d7dedbf48e3..f513fa2a4df8cbffd4263b3700ed9e5fe0422638 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,20 @@
+2009-07-18 09:55  millert
+
+       * toke.c, toke.l: Fix expansion of %h in #include names.  Fixes
+         bugzilla 363
+
+2009-07-12 17:17  millert
+
+       * mkdefaults: If no arg assume def_data.in
+
+2009-07-11 21:27  millert
+
+       * README, WHATSNEW: Update for 1.7.2
+
+2009-07-11 21:12  millert
+
+       * ChangeLog: sync
+
 2009-06-30 08:41  millert
 
        * sudoers.cat, sudoers.man.in, sudoers.pod: Add missing single
 2004-10-01 10:58  millert
 
        * sample.pam, sample.sudoers, sample.syslog.conf, sudoers: Add
-         $Sudo: ChangeLog,v 1.22 2009/07/12 01:12:29 millert Exp $ tags.
+         $Sudo$ tags.
 
 2004-10-01 10:47  millert
 
index 1d45b2118a18c1df9b8d3c9375a433ed3e81f674..3dccf96595abf45818ed2250c67763472a8dbc82 100755 (executable)
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.61 for sudo 1.7.2.
+# Generated by GNU Autoconf 2.61 for sudo 1.7.2p1.
 #
 # Report bugs to <http://www.sudo.ws/bugs/>.
 #
@@ -724,8 +724,8 @@ SHELL=${CONFIG_SHELL-/bin/sh}
 # Identity of this package.
 PACKAGE_NAME='sudo'
 PACKAGE_TARNAME='sudo'
-PACKAGE_VERSION='1.7.2'
-PACKAGE_STRING='sudo 1.7.2'
+PACKAGE_VERSION='1.7.2p1'
+PACKAGE_STRING='sudo 1.7.2p1'
 PACKAGE_BUGREPORT='http://www.sudo.ws/bugs/'
 
 # Factoring default headers for most tests.
@@ -1416,7 +1416,7 @@ if test "$ac_init_help" = "long"; then
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures sudo 1.7.2 to adapt to many kinds of systems.
+\`configure' configures sudo 1.7.2p1 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1481,7 +1481,7 @@ fi
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
-     short | recursive ) echo "Configuration of sudo 1.7.2:";;
+     short | recursive ) echo "Configuration of sudo 1.7.2p1:";;
    esac
   cat <<\_ACEOF
 
@@ -1683,7 +1683,7 @@ fi
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-sudo configure 1.7.2
+sudo configure 1.7.2p1
 generated by GNU Autoconf 2.61
 
 Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
@@ -1697,7 +1697,7 @@ cat >config.log <<_ACEOF
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by sudo $as_me 1.7.2, which was
+It was created by sudo $as_me 1.7.2p1, which was
 generated by GNU Autoconf 2.61.  Invocation command line was
 
   $ $0 $@
@@ -24462,7 +24462,7 @@ exec 6>&1
 # report actual input values of CONFIG_FILES etc. instead of their
 # values after options handling.
 ac_log="
-This file was extended by sudo $as_me 1.7.2, which was
+This file was extended by sudo $as_me 1.7.2p1, which was
 generated by GNU Autoconf 2.61.  Invocation command line was
 
   CONFIG_FILES    = $CONFIG_FILES
@@ -24511,7 +24511,7 @@ Report bugs to <bug-autoconf@gnu.org>."
 _ACEOF
 cat >>$CONFIG_STATUS <<_ACEOF
 ac_cs_version="\\
-sudo config.status 1.7.2
+sudo config.status 1.7.2p1
 configured by $0, generated by GNU Autoconf 2.61,
   with options \\"`echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`\\"
 
index e21ad6fe7b0e683c662d4ddba1800db3bc2d1a62..a59f37aa9e40332458ed01c2ed7e4d05f1d223f5 100644 (file)
@@ -4,7 +4,7 @@ dnl $Sudo: configure.in,v 1.549 2009/06/13 20:52:50 millert Exp $
 dnl
 dnl Copyright (c) 1994-1996,1998-2009 Todd C. Miller <Todd.Miller@courtesan.com>
 dnl
-AC_INIT([sudo], [1.7.2], [http://www.sudo.ws/bugs/], [sudo])
+AC_INIT([sudo], [1.7.2p1], [http://www.sudo.ws/bugs/], [sudo])
 AC_CONFIG_HEADER(config.h pathnames.h)
 dnl
 dnl This won't work before AC_INIT
index f125e045258ba4fe2495d05e96cebf82fd831eea..2a0ba8d7cef518d20023e4d1a67b606096db1053 100755 (executable)
@@ -16,9 +16,9 @@ if ($#ARGV > 0 && $ARGV[0] eq "-o") {
     $header .= '.h';
     $cfile .= '.c';
 }
-die "usage: $0 input_file\n" unless $#ARGV == 0;
+die "usage: $0 [input_file]\n" unless $#ARGV == -1 || $#ARGV == 0;
 
-$infile = $ARGV[0];
+$infile = $ARGV[0] || "def_data.in";
 if (!defined($header)) {
     $header = $infile;
     $header =~ s/(\.in)?$/.h/;
index c7375477c7040de347d248d308e3a6477e11a612..4c9151c30b10c7af00dbdb67b0063ad506428b0a 100644 (file)
--- a/sudo.cat
+++ b/sudo.cat
@@ -61,7 +61,7 @@ D\bDE\bES\bSC\bCR\bRI\bIP\bPT\bTI\bIO\bON\bN
 
 
 
-1.7.2                     June 15, 2009                         1
+1.7.2p1                   June 15, 2009                         1
 
 
 
@@ -127,7 +127,7 @@ O\bOP\bPT\bTI\bIO\bON\bNS\bS
 
 
 
-1.7.2                     June 15, 2009                         2
+1.7.2p1                   June 15, 2009                         2
 
 
 
@@ -193,7 +193,7 @@ SUDO(1m)               MAINTENANCE COMMANDS              SUDO(1m)
 
 
 
-1.7.2                     June 15, 2009                         3
+1.7.2p1                   June 15, 2009                         3
 
 
 
@@ -259,7 +259,7 @@ SUDO(1m)               MAINTENANCE COMMANDS              SUDO(1m)
 
 
 
-1.7.2                     June 15, 2009                         4
+1.7.2p1                   June 15, 2009                         4
 
 
 
@@ -325,7 +325,7 @@ SUDO(1m)               MAINTENANCE COMMANDS              SUDO(1m)
 
 
 
-1.7.2                     June 15, 2009                         5
+1.7.2p1                   June 15, 2009                         5
 
 
 
@@ -391,7 +391,7 @@ S\bSE\bEC\bCU\bUR\bRI\bIT\bTY\bY N\bNO\bOT\bTE\bES\bS
 
 
 
-1.7.2                     June 15, 2009                         6
+1.7.2p1                   June 15, 2009                         6
 
 
 
@@ -457,7 +457,7 @@ E\bEN\bNV\bVI\bIR\bRO\bON\bNM\bME\bEN\bNT\bT
 
 
 
-1.7.2                     June 15, 2009                         7
+1.7.2p1                   June 15, 2009                         7
 
 
 
@@ -523,7 +523,7 @@ E\bEX\bXA\bAM\bMP\bPL\bLE\bES\bS
 
 
 
-1.7.2                     June 15, 2009                         8
+1.7.2p1                   June 15, 2009                         8
 
 
 
@@ -589,7 +589,7 @@ C\bCA\bAV\bVE\bEA\bAT\bTS\bS
 
 
 
-1.7.2                     June 15, 2009                         9
+1.7.2p1                   June 15, 2009                         9
 
 
 
@@ -655,6 +655,6 @@ D\bDI\bIS\bSC\bCL\bLA\bAI\bIM\bME\bER\bR
 
 
 
-1.7.2                     June 15, 2009                        10
+1.7.2p1                   June 15, 2009                        10
 
 
index 13c0d6d84b1e3def07d560b3396671c72a0f327b..1188947ce9fd391819f8c3927f3e798a73765daa 100644 (file)
 .\" ========================================================================
 .\"
 .IX Title "SUDO @mansectsu@"
-.TH SUDO @mansectsu@ "June 15, 2009" "1.7.2" "MAINTENANCE COMMANDS"
+.TH SUDO @mansectsu@ "June 15, 2009" "1.7.2p1" "MAINTENANCE COMMANDS"
 .\" For nroff, turn off justification.  Always turn off hyphenation; it makes
 .\" way too many mistakes in technical documents.
 .if n .ad l
index 1afd9269d3520037b7cf6b835041528a2f983c44..324b278744ddb3017d9efeb46d3348c45c017b6a 100644 (file)
@@ -61,7 +61,7 @@ D\bDE\bES\bSC\bCR\bRI\bIP\bPT\bTI\bIO\bON\bN
 
 
 
-1.7.2                     June 30, 2009                         1
+1.7.2p1                   June 30, 2009                         1
 
 
 
@@ -127,7 +127,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                         2
+1.7.2p1                   June 30, 2009                         2
 
 
 
@@ -193,7 +193,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                         3
+1.7.2p1                   June 30, 2009                         3
 
 
 
@@ -259,7 +259,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                         4
+1.7.2p1                   June 30, 2009                         4
 
 
 
@@ -325,7 +325,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                         5
+1.7.2p1                   June 30, 2009                         5
 
 
 
@@ -391,7 +391,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                         6
+1.7.2p1                   June 30, 2009                         6
 
 
 
@@ -457,7 +457,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                         7
+1.7.2p1                   June 30, 2009                         7
 
 
 
@@ -523,7 +523,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                         8
+1.7.2p1                   June 30, 2009                         8
 
 
 
@@ -589,7 +589,7 @@ S\bSU\bUD\bDO\bOE\bER\bRS\bS O\bOP\bPT\bTI\bIO\bON\bNS\bS
 
 
 
-1.7.2                     June 30, 2009                         9
+1.7.2p1                   June 30, 2009                         9
 
 
 
@@ -655,7 +655,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        10
+1.7.2p1                   June 30, 2009                        10
 
 
 
@@ -721,7 +721,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        11
+1.7.2p1                   June 30, 2009                        11
 
 
 
@@ -787,7 +787,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        12
+1.7.2p1                   June 30, 2009                        12
 
 
 
@@ -853,7 +853,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        13
+1.7.2p1                   June 30, 2009                        13
 
 
 
@@ -919,7 +919,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        14
+1.7.2p1                   June 30, 2009                        14
 
 
 
@@ -985,7 +985,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        15
+1.7.2p1                   June 30, 2009                        15
 
 
 
@@ -1051,7 +1051,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        16
+1.7.2p1                   June 30, 2009                        16
 
 
 
@@ -1117,7 +1117,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        17
+1.7.2p1                   June 30, 2009                        17
 
 
 
@@ -1183,7 +1183,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        18
+1.7.2p1                   June 30, 2009                        18
 
 
 
@@ -1249,7 +1249,7 @@ E\bEX\bXA\bAM\bMP\bPL\bLE\bES\bS
 
 
 
-1.7.2                     June 30, 2009                        19
+1.7.2p1                   June 30, 2009                        19
 
 
 
@@ -1315,7 +1315,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        20
+1.7.2p1                   June 30, 2009                        20
 
 
 
@@ -1381,7 +1381,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        21
+1.7.2p1                   June 30, 2009                        21
 
 
 
@@ -1447,7 +1447,7 @@ SUDOERS(4)             MAINTENANCE COMMANDS            SUDOERS(4)
 
 
 
-1.7.2                     June 30, 2009                        22
+1.7.2p1                   June 30, 2009                        22
 
 
 
@@ -1513,7 +1513,7 @@ P\bPR\bRE\bEV\bVE\bEN\bNT\bTI\bIN\bNG\bG S\bSH\bHE\bEL\bLL\bL E\bES\bSC\bCA\bAP\bPE\bES\bS
 
 
 
-1.7.2                     June 30, 2009                        23
+1.7.2p1                   June 30, 2009                        23
 
 
 
@@ -1579,7 +1579,7 @@ S\bSU\bUP\bPP\bPO\bOR\bRT\bT
 
 
 
-1.7.2                     June 30, 2009                        24
+1.7.2p1                   June 30, 2009                        24
 
 
 
@@ -1645,6 +1645,6 @@ D\bDI\bIS\bSC\bCL\bLA\bAI\bIM\bME\bER\bR
 
 
 
-1.7.2                     June 30, 2009                        25
+1.7.2p1                   June 30, 2009                        25
 
 
index 234931dea9994e28f152476ca994b0e1d6e4167a..e95ffc07c501f67cdb15b15a72ab034104d7e515 100644 (file)
@@ -61,7 +61,7 @@ D\bDE\bES\bSC\bCR\bRI\bIP\bPT\bTI\bIO\bON\bN
 
 
 
-1.7.2                     June 11, 2009                         1
+1.7.2p1                   June 11, 2009                         1
 
 
 
@@ -127,7 +127,7 @@ SUDOERS.LDAP(4)        MAINTENANCE COMMANDS       SUDOERS.LDAP(4)
 
 
 
-1.7.2                     June 11, 2009                         2
+1.7.2p1                   June 11, 2009                         2
 
 
 
@@ -193,7 +193,7 @@ SUDOERS.LDAP(4)        MAINTENANCE COMMANDS       SUDOERS.LDAP(4)
 
 
 
-1.7.2                     June 11, 2009                         3
+1.7.2p1                   June 11, 2009                         3
 
 
 
@@ -259,7 +259,7 @@ SUDOERS.LDAP(4)        MAINTENANCE COMMANDS       SUDOERS.LDAP(4)
 
 
 
-1.7.2                     June 11, 2009                         4
+1.7.2p1                   June 11, 2009                         4
 
 
 
@@ -325,7 +325,7 @@ SUDOERS.LDAP(4)        MAINTENANCE COMMANDS       SUDOERS.LDAP(4)
 
 
 
-1.7.2                     June 11, 2009                         5
+1.7.2p1                   June 11, 2009                         5
 
 
 
@@ -391,7 +391,7 @@ SUDOERS.LDAP(4)        MAINTENANCE COMMANDS       SUDOERS.LDAP(4)
 
 
 
-1.7.2                     June 11, 2009                         6
+1.7.2p1                   June 11, 2009                         6
 
 
 
@@ -457,7 +457,7 @@ SUDOERS.LDAP(4)        MAINTENANCE COMMANDS       SUDOERS.LDAP(4)
 
 
 
-1.7.2                     June 11, 2009                         7
+1.7.2p1                   June 11, 2009                         7
 
 
 
@@ -523,7 +523,7 @@ SUDOERS.LDAP(4)        MAINTENANCE COMMANDS       SUDOERS.LDAP(4)
 
 
 
-1.7.2                     June 11, 2009                         8
+1.7.2p1                   June 11, 2009                         8
 
 
 
@@ -589,7 +589,7 @@ E\bEX\bXA\bAM\bMP\bPL\bLE\bES\bS
 
 
 
-1.7.2                     June 11, 2009                         9
+1.7.2p1                   June 11, 2009                         9
 
 
 
@@ -655,7 +655,7 @@ SUDOERS.LDAP(4)        MAINTENANCE COMMANDS       SUDOERS.LDAP(4)
 
 
 
-1.7.2                     June 11, 2009                        10
+1.7.2p1                   June 11, 2009                        10
 
 
 
@@ -721,7 +721,7 @@ SUDOERS.LDAP(4)        MAINTENANCE COMMANDS       SUDOERS.LDAP(4)
 
 
 
-1.7.2                     June 11, 2009                        11
+1.7.2p1                   June 11, 2009                        11
 
 
 
@@ -787,6 +787,6 @@ D\bDI\bIS\bSC\bCL\bLA\bAI\bIM\bME\bER\bR
 
 
 
-1.7.2                     June 11, 2009                        12
+1.7.2p1                   June 11, 2009                        12
 
 
index e4e172f3a7bbe17a46b4919aeb28bd600d861943..331dbdb4b77a4dec31a855fc284a79cc3583dbcb 100644 (file)
 .\" ========================================================================
 .\"
 .IX Title "SUDOERS.LDAP @mansectform@"
-.TH SUDOERS.LDAP @mansectform@ "June 11, 2009" "1.7.2" "MAINTENANCE COMMANDS"
+.TH SUDOERS.LDAP @mansectform@ "June 11, 2009" "1.7.2p1" "MAINTENANCE COMMANDS"
 .\" For nroff, turn off justification.  Always turn off hyphenation; it makes
 .\" way too many mistakes in technical documents.
 .if n .ad l
index 60d56edfe08a570157be565d885b653b40e734a5..7b21d20a2b7f48f04f0000748615a6090c7eda05 100644 (file)
 .\" ========================================================================
 .\"
 .IX Title "SUDOERS @mansectform@"
-.TH SUDOERS @mansectform@ "June 30, 2009" "1.7.2" "MAINTENANCE COMMANDS"
+.TH SUDOERS @mansectform@ "June 30, 2009" "1.7.2p1" "MAINTENANCE COMMANDS"
 .\" For nroff, turn off justification.  Always turn off hyphenation; it makes
 .\" way too many mistakes in technical documents.
 .if n .ad l
diff --git a/toke.c b/toke.c
index a4bcb8eaa53d73d2a25ea2f43919d32221981fd0..96eaf51cecc43e7bbc10c6caa281af9b9cf7394c 100644 (file)
--- a/toke.c
+++ b/toke.c
@@ -3,7 +3,7 @@
 /* A lexical scanner generated by flex */
 
 /* Scanner skeleton version:
- * $Header: /home/cvs/courtesan/sudo/toke.c,v 1.36 2009/05/27 00:47:17 millert Exp $
+ * $Header: /home/cvs/courtesan/sudo/toke.c,v 1.37 2009/07/18 13:55:37 millert Exp $
  */
 
 #define FLEX_SCANNER
@@ -1417,7 +1417,7 @@ char *yytext;
 #include <gram.h>
 
 #ifndef lint
-__unused static const char rcsid[] = "$Sudo: toke.c,v 1.36 2009/05/27 00:47:17 millert Exp $";
+__unused static const char rcsid[] = "$Sudo: toke.c,v 1.37 2009/07/18 13:55:37 millert Exp $";
 #endif /* lint */
 
 extern YYSTYPE yylval;
@@ -3592,6 +3592,7 @@ parse_include(base)
                memcpy(pp, user_shost, shost_len);
                pp += shost_len;
                cp += 2;
+               continue;
            }
            *pp++ = *cp++;
        }
diff --git a/toke.l b/toke.l
index 9b93563558f3f4e7260a59268e0584b363aa6c00..3fbfd2c36b7efeec2b72407bd46cbd6f3f55b1ea 100644 (file)
--- a/toke.l
+++ b/toke.l
@@ -72,7 +72,7 @@
 #include <gram.h>
 
 #ifndef lint
-__unused static const char rcsid[] = "$Sudo: toke.l,v 1.37 2009/05/27 00:46:51 millert Exp $";
+__unused static const char rcsid[] = "$Sudo: toke.l,v 1.38 2009/07/18 13:55:37 millert Exp $";
 #endif /* lint */
 
 extern YYSTYPE yylval;
@@ -971,6 +971,7 @@ parse_include(base)
                memcpy(pp, user_shost, shost_len);
                pp += shost_len;
                cp += 2;
+               continue;
            }
            *pp++ = *cp++;
        }
index 51c822e7ae88af5f9cceccb971043920cedadedc..db6aa532accdb816bbe4845e4d54ef5489191b65 100644 (file)
@@ -61,7 +61,7 @@ O\bOP\bPT\bTI\bIO\bON\bNS\bS
 
 
 
-1.7.2                     June 11, 2009                         1
+1.7.2p1                   June 11, 2009                         1
 
 
 
@@ -127,7 +127,7 @@ A\bAU\bUT\bTH\bHO\bOR\bR
 
 
 
-1.7.2                     June 11, 2009                         2
+1.7.2p1                   June 11, 2009                         2
 
 
 
@@ -193,6 +193,6 @@ D\bDI\bIS\bSC\bCL\bLA\bAI\bIM\bME\bER\bR
 
 
 
-1.7.2                     June 11, 2009                         3
+1.7.2p1                   June 11, 2009                         3
 
 
index dc33f549ec1ad95d92e3c683c8cfdb812191bfc1..2f7becbb0897c864e0f87e3f4c2b99ac1e913986 100644 (file)
 .\" ========================================================================
 .\"
 .IX Title "VISUDO @mansectsu@"
-.TH VISUDO @mansectsu@ "June 11, 2009" "1.7.2" "MAINTENANCE COMMANDS"
+.TH VISUDO @mansectsu@ "June 11, 2009" "1.7.2p1" "MAINTENANCE COMMANDS"
 .\" For nroff, turn off justification.  Always turn off hyphenation; it makes
 .\" way too many mistakes in technical documents.
 .if n .ad l