Imported Debian patch 1.1.0-1 debian/1.1.0-1
authorBdale Garbee <bdale@gag.com>
Sun, 29 Feb 2004 05:25:40 +0000 (22:25 -0700)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 23:33:46 +0000 (17:33 -0600)
debian/changelog [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/dirs [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/rules [new file with mode: 0755]
utils/fontdata.c

diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..0fde5b0
--- /dev/null
@@ -0,0 +1,18 @@
+splat (1.1.0-1) unstable; urgency=low
+
+  * new upstream version, closes: #234621
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 28 Feb 2004 22:25:40 -0700
+
+splat (1.0.3-1) unstable; urgency=low
+
+  * new upstream version, closes: #149717
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 17 Aug 2002 22:38:09 -0600
+
+splat (1.0.0-1) unstable; urgency=low
+
+  * Initial Release.
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 22 Apr 2002 00:03:05 -0600
+
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..a350f9d
--- /dev/null
@@ -0,0 +1,15 @@
+Source: splat
+Section: hamradio
+Priority: optional
+Maintainer: Bdale Garbee <bdale@gag.com>
+Build-Depends: debhelper (>> 3.0.0), libbz2-dev, zlib1g-dev
+Standards-Version: 3.6.1.0
+
+Package: splat
+Architecture: any
+Depends: ${shlibs:Depends}, gnuplot
+Description: analyze point-to-point terrestrial RF communication links
+ SPLAT! is a Surface Path Length And Terrain analysis application written 
+ for Linux and Unix workstations.  SPLAT! analyzes point-to-point terrestrial 
+ RF communication links, and provides information useful to communication 
+ system designers and site engineers. 
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..2e0c303
--- /dev/null
@@ -0,0 +1,16 @@
+This package was debianized by Bdale Garbee <bdale@gag.com> on
+Mon, 22 Apr 2002 00:03:05 -0600.
+
+It was downloaded from http://www.qsl.net/kd2bd/splat.html
+
+Upstream Author: John A Magliacane, KD2BD
+
+Copyright:
+
+       Copyright John A. Magliacane, KD2BD 1997-2002
+
+       GPL
+
+On Debian GNU/Linux systems, the complete text of the GNU General Public
+License can be found in the `/usr/share/common-licenses' directory.
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644 (file)
index 0000000..98d1583
--- /dev/null
@@ -0,0 +1,2 @@
+usr/bin
+usr/share/man/man1
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..e845566
--- /dev/null
@@ -0,0 +1 @@
+README
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..aeebddd
--- /dev/null
@@ -0,0 +1,61 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatibility version to use.
+export DH_COMPAT=3
+
+build: build-stamp
+build-stamp: 
+       dh_testdir      
+       ./build all
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp 
+       rm -f splat utils/fontdata utils/citydecoder utils/usgs2sdf
+       dh_clean
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs
+       cp splat $(CURDIR)/debian/splat/usr/bin
+       cp utils/citydecoder $(CURDIR)/debian/splat/usr/bin
+       cp utils/usgs2sdf $(CURDIR)/debian/splat/usr/bin
+       cp utils/fontdata $(CURDIR)/debian/splat/usr/bin
+       cp docs/man/splat.man $(CURDIR)/debian/splat/usr/share/man/man1/splat.1
+
+# Build architecture-independent files here.
+binary-indep: build install
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installexamples
+       dh_installmenu
+       dh_installcron
+       dh_installman
+       dh_installinfo
+#      dh_undocumented
+       dh_installchangelogs 
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install 
index f04e54635dc29b489d720d08b8e4f8e07b7cd8f0..b156817ff4f2bee9c0f225e8d09083e4ff963b2e 100644 (file)
@@ -32,6 +32,7 @@
 #include <string.h>
 #include <stdlib.h>
 #include <zlib.h>
+#include <stdlib.h>
 
 int main(argc,argv)
 int argc;