Imported Debian patch 21-9
[debian/pforth] / Makefile
index 40a3fc391f409023b60ca79577257fb00c2584e8..b500704e7b2a026c483e65d39120122b6ae2584b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -18,7 +18,6 @@ FULL_WARNINGS =  -O2 \
         -fno-unroll-loops \
         -fpeephole \
         -fno-keep-inline-functions \
-        -x c++ \
         -Wcast-qual \
         -Wall \
         -Wwrite-strings \
@@ -69,7 +68,7 @@ pforth: $(PFINCLUDES) $(PFOBJS)
 
 # build basic dictionary by running newly built pforth and including system.fth
 pforth.dic: pforth
-       pforth -i system.fth
+       ./pforth -i system.fth
 
 ${SOURCEDIR}/pfdicdat.h: pforth pforth.dic
        @(echo 'INCLUDE utils/savedicd.fth'; \