Imported Debian patch 21-9 debian/21-9
authorBdale Garbee <bdale@gag.com>
Mon, 28 Jan 2002 16:20:13 +0000 (09:20 -0700)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 23:31:29 +0000 (17:31 -0600)
Makefile
csrc/pf_main.c
debian/changelog [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/dirs [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/pforth.1 [new file with mode: 0644]
debian/rules [new file with mode: 0755]

index 40a3fc391f409023b60ca79577257fb00c2584e8..b500704e7b2a026c483e65d39120122b6ae2584b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -18,7 +18,6 @@ FULL_WARNINGS =  -O2 \
         -fno-unroll-loops \
         -fpeephole \
         -fno-keep-inline-functions \
-        -x c++ \
         -Wcast-qual \
         -Wall \
         -Wwrite-strings \
@@ -69,7 +68,7 @@ pforth: $(PFINCLUDES) $(PFOBJS)
 
 # build basic dictionary by running newly built pforth and including system.fth
 pforth.dic: pforth
-       pforth -i system.fth
+       ./pforth -i system.fth
 
 ${SOURCEDIR}/pfdicdat.h: pforth pforth.dic
        @(echo 'INCLUDE utils/savedicd.fth'; \
index e834f14fdecfb7d303e5735ba6db2d46eb03e128..6edbe17ac020b0f4bbbfe988b61f86dbb9c269cf 100644 (file)
@@ -42,7 +42,7 @@
 
 int main( int argc, char **argv )
 {
-       const char *DicName = "pforth.dic";
+       const char *DicName = "/usr/lib/pforth/pforth.dic";
        const char *SourceName = NULL;
        char IfInit = FALSE;
        char *s;
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..4152b27
--- /dev/null
@@ -0,0 +1,72 @@
+pforth (21-9) unstable; urgency=low
+
+  * add hppa to list of supported architectures, closes: #131276
+  * lose the '-x c++' from the Makefile, since it appears bogus (pForth is 
+    ANSI C, not C++) and hppa fails to link if it is using gcc for C++.  
+    Thanks to James Troup for figuring this out.
+  * clean up a few cosmetic uglies and make lintian happy
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 28 Jan 2002 09:20:13 -0700
+
+pforth (21-8) unstable; urgency=low
+
+  * add s390 to list of supported architectures, closes: #127760
+
+ -- Bdale Garbee <bdale@gag.com>  Fri,  4 Jan 2002 10:08:52 -0700
+
+pforth (21-7) unstable; urgency=low
+
+  * clean up lintian reports
+
+ -- Bdale Garbee <bdale@gag.com>  Tue,  1 Jan 2002 10:30:48 -0700
+
+pforth (21-6) unstable; urgency=low
+
+  * add hurd-i386 to supported architectures in control, closes: #55122
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 14 Jan 2000 23:51:08 -0700
+
+pforth (21-5) unstable; urgency=low
+
+  * prefix invocation of new pforth binary in makefile with './' so that '.'
+    doesn't need to be in builder's path.  Closes: #53627
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 28 Dec 1999 10:42:18 -0700
+
+pforth (21-4) unstable; urgency=low
+
+  * recompile so libstdc++ dependency is current for potato, closes: #53452
+  * building on alpha was "fixed" in -3 by using an explicit arch list, and
+    there's no sign of an alpha port.  Closes: #39298
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 27 Dec 1999 11:16:32 -0700
+
+pforth (21-3) unstable; urgency=low
+
+  * switch to an explicit architecture specification in the control file,
+    since this is a 32-bit implementation, doesn't work on alpha, and is
+    unlikely to work out of the box on other new processors that come along.
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 19 Jun 1999 10:45:10 -0600
+
+pforth (21-2) unstable; urgency=low
+
+  * oops, fix a typo in the man page
+  * include the rest of the documentation provided with the upstream sources
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 27 Dec 1998 12:22:42 -0700
+
+pforth (21-1) unstable; urgency=low
+
+  * move to newer upstream source pointed out by author
+  * implement central default location for pforth.dic file, providing diffs 
+    to upstream author
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 27 Dec 1998 09:16:11 -0700
+
+pforth (19-1) unstable; urgency=low
+
+  * Initial packaging of pforth, never uploaded.
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 24 Dec 1998 01:55:27 -0700
+
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..5d191d7
--- /dev/null
@@ -0,0 +1,15 @@
+Source: pforth
+Section: interpreters
+Priority: optional
+Maintainer: Bdale Garbee <bdale@gag.com>
+Build-Depends: debhelper
+Standards-Version: 3.5.6.0
+
+Package: pforth
+Architecture: arm i386 m68k powerpc s390 sparc hurd-i386 hppa
+Depends: ${shlibs:Depends}
+Description: portable Forth interpreter
+ pForth is a public domain, portable ANS Forth based on a kernel written in
+ ANSI 'C'.  This makes it easy to port pForth to multiple platforms.
+ .
+ More information on pForth is available at http://www.softsynth.com/pforth/
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..62f37fd
--- /dev/null
@@ -0,0 +1,16 @@
+This package was debianized by Bdale Garbee bdale@gag.com on
+Thu, 24 Dec 1998 01:55:27 -0700.
+
+It was downloaded from http://www.softsynth.com/pforth/
+
+Upstream Author(s): Phil Burk, philburk@softsynth.com
+
+Copyright:
+
+The pForth software code is dedicated to the public domain, and any third 
+party may reproduce, distribute and modify the pForth software code or any 
+derivative works thereof without any compensation or license. The pForth 
+software code is provided on an "as is" basis without any warranty of any 
+kind, including, without limitation, the implied warranties of merchantability
+and fitness for a particular purpose and their equivalents under the laws 
+of any jurisdiction.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644 (file)
index 0000000..8472c54
--- /dev/null
@@ -0,0 +1,2 @@
+usr/bin
+usr/lib/pforth
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..065531a
--- /dev/null
@@ -0,0 +1,5 @@
+README.txt 
+docs/pf_ref.htm
+docs/pf_todo.txt
+docs/pf_tut.htm
+docs/pfmanual.txt
diff --git a/debian/pforth.1 b/debian/pforth.1
new file mode 100644 (file)
index 0000000..bfd0bf9
--- /dev/null
@@ -0,0 +1,39 @@
+.TH PFORTH 1
+.\" NAME should be all caps, SECTION should be 1-8, maybe w/ subsection
+.\" other parms are allowed: see man(7), man(1)
+.SH NAME
+pForth \- an ANS Forth interpreter written in ANSI 'C'
+.SH SYNOPSIS
+.B pforth
+.I "[options] files ..."
+.SH "DESCRIPTION"
+This manual page was written for the Debian GNU/Linux distribution
+because the original program does not have a manual page.
+.PP
+.B pForth
+is an interpreter for the ANS Forth language.  It implements the Core,
+Core Extensions, File-Access, Floating-Point, Locals, Programming-Tools,
+and Strings word sets.
+.PP
+Any files specified on the command line will be processed as if typed.  This
+is useful for scripting.
+.SH OPTIONS
+.TP
+.B \-d<filename.dic>
+Specify an alternate dictionary.  By default, pforth.dic will be searched for
+first in the current directory, and then in /usr/lib/pforth.
+.TP
+.B \-i
+Initialization mode, used for creating an initial dictionary.
+.TP
+.B \-q
+Quiet mode.
+.SH "SEE ALSO"
+There are some other pForth docs in /usr/doc/pforth, and a web page at
+http://www.softsynth.com/pforth/.  
+.PP
+Information on Forth in general
+is available from the Forth Interest Group web site at http://www.forth.org/.
+.SH AUTHOR
+This manual page was written by Bdale Garbee <bdale@gag.com>
+for the Debian GNU/Linux system (but may be used by others).
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..412cd0f
--- /dev/null
@@ -0,0 +1,62 @@
+#!/usr/bin/make -f
+# MAde with the aid of dh_make, by Craig Small
+# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+# Some lines taken from debmake, by Cristoph Lameter.
+
+# comment this to turn off verbose mode.
+export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+       dh_testdir
+       mkdir objects
+       $(MAKE) 
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp install-stamp
+       -$(MAKE) clean
+       rm -fr objects
+       dh_clean
+
+install: install-stamp
+install-stamp: build-stamp
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs
+
+       install -m0755 pforth `pwd`/debian/tmp/usr/bin/pforth
+       install -m0644 pforth.dic `pwd`/debian/tmp/usr/lib/pforth/pforth.dic
+
+       touch install-stamp
+
+# Build architecture-independent files here.
+binary-indep: build install
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installexamples
+       dh_installmenu
+       dh_installcron
+       dh_installmanpages
+       dh_installchangelogs 
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+source diff:                                                                  
+       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary