Imported Debian patch 1.5-16 debian/1.5-16
authorBdale Garbee <bdale@gag.com>
Wed, 12 Dec 2007 06:13:03 +0000 (23:13 -0700)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 23:30:10 +0000 (17:30 -0600)
debian/changelog
debian/compat [new file with mode: 0644]
debian/control
debian/rules
pat_rep.c
types.h

index 01f455c041702d1967e440af8b8032615517196d..71abf20b76d691dbfd101b5429f411813ce0931e 100644 (file)
@@ -1,3 +1,10 @@
+pax (1:1.5-16) unstable; urgency=low
+
+  * patch for -s irregularities from Stephane Chazelas, closes: #451361
+  * clean up various lintian warnings
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 11 Dec 2007 23:13:03 -0700
+
 pax (1:1.5-15) unstable; urgency=low
 
   * update priority in control file to match override
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..7ed6ff8
--- /dev/null
@@ -0,0 +1 @@
+5
index 0a5830b5312f5cc0ce2daee01504afad0847f12d..3cc53b23ff44888867f66e4e82be0fcde5018ed7 100644 (file)
@@ -3,7 +3,7 @@ Section: utils
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
 Build-Depends: debhelper
-Standards-Version: 3.6.1.0
+Standards-Version: 3.7.3
 
 Package: pax
 Architecture: any
index 9df2b74ca8b2da0fe256a5f14d0085174b21123d..7b9110715fb89a25ee7c05af01063f84d2a9d446 100755 (executable)
@@ -16,7 +16,7 @@ clean:
        dh_testroot
        rm -f build-stamp install-stamp
 
-       -$(MAKE) realclean
+       [ ! -f Makefile ] || $(MAKE) realclean
 
        dh_clean
 
@@ -27,7 +27,7 @@ install-stamp: build-stamp
        dh_clean -k
        dh_installdirs
 
-       $(MAKE) prefix=`pwd`/debian/tmp/usr install
+       $(MAKE) prefix=`pwd`/debian/pax/usr install
 
        touch install-stamp
 
index a93809f743692c9e4b1a2a9cdc60184caba81b17..03b9a8199d0950cdc3aff870c43b3cc32592a545 100644 (file)
--- a/pat_rep.c
+++ b/pat_rep.c
@@ -85,7 +85,7 @@ static char * range_match __P((register char *, register int));
 #ifdef NET2_REGEX
 static int resub __P((regexp *, char *, char *, register char *));
 #else
-static int resub __P((regex_t *, regmatch_t *, char *, char *, char *));
+static int resub __P((regex_t *, regmatch_t *, char *, char *, char *, char *));
 #endif
 
 /*
@@ -1020,7 +1020,7 @@ rep_name(name, nlen, prnt)
 #                      ifdef NET2_REGEX
                        if ((res = resub(pt->rcmp,pt->nstr,outpt,endpt)) < 0) {
 #                      else
-                       if ((res = resub(&(pt->rcmp),pm,pt->nstr,outpt,endpt))
+                       if ((res = resub(&(pt->rcmp),pm,inpt,pt->nstr,outpt,endpt))
                            < 0) {
 #                      endif
                                if (prnt)
@@ -1172,7 +1172,7 @@ resub(prog, src, dest, destend)
 
 #ifdef __STDC__
 static int
-resub(regex_t *rp, register regmatch_t *pm, char *src, char *dest,
+resub(regex_t *rp, register regmatch_t *pm, char *orig, char *src, char *dest,
        register char *destend)
 #else
 static int
@@ -1231,7 +1231,7 @@ resub(rp, pm, src, dest, destend)
                 */
                if (len > (destend - dpt))
                        len = destend - dpt;
-               if (l_strncpy(dpt, src + pmpt->rm_so, len) != len)
+               if (l_strncpy(dpt, orig + pmpt->rm_so, len) != len)
                        return(-1);
                dpt += len;
        }
diff --git a/types.h b/types.h
index baf4d8dc431332accc60f622fa08b65d4a6a9006..a38bb39e4880f311fe4a6360360cbaafc47f4cca 100644 (file)
--- a/types.h
+++ b/types.h
@@ -36,7 +36,7 @@
  * SUCH DAMAGE.
  *
  *     @(#)types.h     8.4 (Berkeley) 1/21/94
- * $Id: types.h,v 1.1 2001/07/23 05:20:01 bdale Exp $
+ * $Id: types.h,v 1.1 2001-07-23 05:20:01 bdale Exp $
  */
 
 #ifndef _SYS_TYPES_H_