move to dh, update standards version, mv git-buildpackage config to .git/
[debian/pax] / debian / rules
index 7b9110715fb89a25ee7c05af01063f84d2a9d446..416dbc8dcd7b244a048b1ccddb31cc8a18fa3b2a 100755 (executable)
@@ -1,61 +1,12 @@
 #!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
 
-# comment this to turn off verbose mode.
 export DH_VERBOSE=1
 
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-       $(MAKE)
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp install-stamp
-
-       [ ! -f Makefile ] || $(MAKE) realclean
-
-       dh_clean
-
-install: install-stamp
-install-stamp: build-stamp
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       $(MAKE) prefix=`pwd`/debian/pax/usr install
-
-       touch install-stamp
-
-# Build architecture-independent files here.
-binary-indep: build install
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installexamples
-       dh_installmenu
-       dh_installcron
-       dh_installmanpages cpio.1 tar.1
-       dh_installchangelogs
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+       dh $@