try to use system libraries instead of delivering local copies
authorBdale Garbee <bdale@gag.com>
Mon, 22 Mar 2010 20:58:37 +0000 (14:58 -0600)
committerBdale Garbee <bdale@gag.com>
Mon, 22 Mar 2010 20:58:37 +0000 (14:58 -0600)
debian/control
debian/patches/series
debian/patches/use-system-libs.diff [new file with mode: 0644]

index 86dce56618e1dce17efecbb79c6841b8d76d67cb..821d626a257c3f762aa75cae9f2b816e89818d0a 100644 (file)
@@ -9,7 +9,7 @@ Vcs-Git: git://git.gag.com/debian/openrocket
 
 Package: openrocket
 Architecture: all
-Depends: ${shlibs:Depends}, ${misc:Depends}, openjdk-6-jre | sun-java6-jre
+Depends: ${shlibs:Depends}, ${misc:Depends}, openjdk-6-jre | sun-java6-jre, libjcommon-java, libjfreechart-java, libmiglayout-java
 Description: Model Rocket Simulator
  OpenRocket is a free, fully featured model rocket simulator that allows 
  you to design and simulate your rockets before actually building and 
index a23bfdd949a98cc490da57a55f136023e850d04c..90e3f12318f39f8965bbf86704f1eceb76d619ad 100644 (file)
@@ -1 +1,2 @@
 openjdk-is-ok.diff
+use-system-libs.diff
diff --git a/debian/patches/use-system-libs.diff b/debian/patches/use-system-libs.diff
new file mode 100644 (file)
index 0000000..e06e473
--- /dev/null
@@ -0,0 +1,21 @@
+diff --git a/build.xml b/build.xml
+index 394aea4..46fdeff 100644
+--- a/build.xml
++++ b/build.xml
+@@ -72,9 +72,6 @@
+                               <attribute name="Main-Class" value="${main-class}"/>
+                               <attribute name="SplashScreen-Image" value="pix/splashscreen.png"/>
+                       </manifest>
+-                      <zipfileset src="lib/miglayout15-swing.jar" />
+-                      <zipfileset src="lib/jcommon-1.0.16.jar" />
+-                      <zipfileset src="lib/jfreechart-1.0.13.jar" />
+               </jar>
+       </target>
+       
+@@ -213,4 +210,4 @@ ${nonascii}</fail>
+               </echo>
+       </target>
+     
+-</project>
+\ No newline at end of file
++</project>