ant needs help to install build results
authorBdale Garbee <bdale@gag.com>
Sun, 14 Mar 2010 00:23:31 +0000 (17:23 -0700)
committerBdale Garbee <bdale@gag.com>
Sun, 14 Mar 2010 00:23:31 +0000 (17:23 -0700)
debian/dirs [new file with mode: 0644]
debian/rules

diff --git a/debian/dirs b/debian/dirs
new file mode 100644 (file)
index 0000000..e4bc73a
--- /dev/null
@@ -0,0 +1,2 @@
+usr/bin
+usr/share/java
index 917d9bf25deb90bc3cd843717dc94359fcc02eb6..6e191deee0be8e8c17adc92809815ada815f829c 100755 (executable)
 
 %:
        dh  $@
+
+override_dh_auto_build:
+       ant dist-bin
+
+override_dh_auto_install:
+       cp build/jar/* `pwd`/debian/openrocket/usr/share/java/
+       echo "#!/bin/sh\njava -jar /usr/share/java/`/bin/ls build/jar`" > \
+               `pwd`/debian/openrocket/usr/bin/openrocket