update to reflect additional build dependency
authorBdale Garbee <bdale@gag.com>
Wed, 9 Mar 2011 04:52:27 +0000 (21:52 -0700)
committerBdale Garbee <bdale@gag.com>
Wed, 9 Mar 2011 04:52:27 +0000 (21:52 -0700)
build.xml
debian/control
lib/iText-5.0.2.jar [deleted file]

index 30f62d25b5109c18b6956348dc39aa65dc75851f..3482ffec84689342ddbddba57d11020d811ebf89 100644 (file)
--- a/build.xml
+++ b/build.xml
@@ -13,7 +13,6 @@
        
        <property name="classes.dir" value="${dist.dir}"/>      <!-- Directory for classes -->
        <property name="jar.dir"     value="${build.dir}/jar"/> <!-- Directory for built jar's -->
-       <property name="lib.dir"     value="lib"/>                              <!-- Library source directory -->
 
        <property name="pkgname"     value="${ant.project.name}-${build.version}"/>
        
        
        <!-- Classpath definitions -->
        <path id="classpath">
-               <fileset dir="${lib.dir}" includes="**/*.jar"/>
+               <!-- update manifest class-path definition below too when making changes here -->
+               <pathelement location="/usr/share/java/jcommon.jar"/>
+               <pathelement location="/usr/share/java/jfreechart.jar"/>
+               <pathelement location="/usr/share/java/miglayout.jar"/>
        </path>
        
        <path id="test-classpath">
@@ -36,7 +38,7 @@
                <pathelement location="${build-test.dir}"/>
                <pathelement location="${classes.dir}"/>
                <pathelement location="${src-test.dir}"/>
-               <fileset dir="lib-test/" includes="*.jar"/>
+               <pathelement location="/usr/share/java/junit4.jar"/>
        </path>
        
 
                        <manifest>
                                <attribute name="Main-Class" value="${main-class}"/>
                                <attribute name="SplashScreen-Image" value="pix/splashscreen.png"/>
+                               <attribute name="Class-Path" value="/usr/share/j
+ava/jcommon.jar /usr/share/java/jfreechart.jar /usr/share/java/miglayout.jar /usr/share/java/itext.jar"/>
                        </manifest>
-                       <zipfileset src="lib/miglayout15-swing.jar" />
-                       <zipfileset src="lib/jcommon-1.0.16.jar" />
-                       <zipfileset src="lib/jfreechart-1.0.13.jar" />
-                       <zipfileset src="lib/iText-5.0.2.jar" />
                </jar>
        </target>
        
@@ -89,7 +89,7 @@
                        <fileset dir="." includes="*">
                                <type type="file"/>
                        </fileset>
-                       <fileset dir="." includes="datafiles/ lib/ lib-test/ pix/ src/ test/"/>
+                       <fileset dir="." includes="datafiles/ pix/ src/ test/"/>
                </copy>
                <zip destfile="${dist.src}" basedir="${build.dir}" includes="${pkgname}/"/>
                <delete dir="${build.dir}/${pkgname}"/>
@@ -213,4 +213,4 @@ ${nonascii}</fail>
                </echo>
        </target>
     
-</project>
\ No newline at end of file
+</project>
index b9c94c80ed4f30709f8c2679d347c6cf38f9abf5..adf854a116f2903bbf1a8fc981a31783ad03f11d 100644 (file)
@@ -2,7 +2,7 @@ Source: openrocket
 Section: science
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>= 7.0.50~), openjdk-6-jdk, ant, ant-optional, libjcommon-java, libjfreechart-java, libmiglayout-java, junit4
+Build-Depends: debhelper (>= 7.0.50~), openjdk-6-jdk, ant, ant-optional, libjcommon-java, libjfreechart-java, libmiglayout-java, junit4, libitext-java
 Standards-Version: 3.9.1
 Homepage: http://openrocket.sourceforge.net/
 Vcs-Git: git://git.gag.com/debian/openrocket
diff --git a/lib/iText-5.0.2.jar b/lib/iText-5.0.2.jar
deleted file mode 100644 (file)
index ed95653..0000000
Binary files a/lib/iText-5.0.2.jar and /dev/null differ