strip the remaining libs from upstream in favor of packaged versions
authorBdale Garbee <bdale@gag.com>
Mon, 22 Mar 2010 23:25:10 +0000 (17:25 -0600)
committerBdale Garbee <bdale@gag.com>
Mon, 22 Mar 2010 23:25:10 +0000 (17:25 -0600)
debian/control
debian/patches/use-system-libs.diff

index c92ce24e8e19e9fb03938ee7241adf94c1be084b..5f95355b99f86accaaa8a9dcd503a756b2adc8e1 100644 (file)
@@ -2,7 +2,7 @@ Source: openrocket
 Section: science
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>= 7.0.50~), openjdk-6-jdk, ant, ant-optional, libjcommon-java, libjfreechart-java, libmiglayout-java
+Build-Depends: debhelper (>= 7.0.50~), openjdk-6-jdk, ant, ant-optional, libjcommon-java, libjfreechart-java, libmiglayout-java, junit4
 Standards-Version: 3.8.4
 Homepage: http://openrocket.sourceforge.net/
 Vcs-Git: git://git.gag.com/debian/openrocket
index 5ea503994dca819719f86c7c6fb4f023de95bfef..24caa9d2b2f5c069838d9382e28a418590acbc53 100644 (file)
@@ -1,8 +1,16 @@
 diff --git a/build.xml b/build.xml
-index 394aea4..d420c52 100644
+index 394aea4..5915b1a 100644
 --- a/build.xml
 +++ b/build.xml
-@@ -28,9 +28,12 @@
+@@ -13,7 +13,6 @@
+       
+       <property name="classes.dir" value="${dist.dir}"/>      <!-- Directory for classes -->
+       <property name="jar.dir"     value="${build.dir}/jar"/> <!-- Directory for built jar's -->
+-      <property name="lib.dir"     value="lib"/>                              <!-- Library source directory -->
+       <property name="pkgname"     value="${ant.project.name}-${build.version}"/>
+       
+@@ -28,16 +27,18 @@
        
        <!-- Classpath definitions -->
        <path id="classpath">
@@ -17,7 +25,15 @@ index 394aea4..d420c52 100644
        <path id="test-classpath">
                <path refid="classpath"/>
                <pathelement location="${basedir}"/>
-@@ -71,10 +74,8 @@
+               <pathelement location="${build-test.dir}"/>
+               <pathelement location="${classes.dir}"/>
+-<!--          <pathelement location="${ant.library.dir}/junit4.jar"/> -->
+-              <pathelement location="lib-test/junit-4.7.jar"/>
++              <pathelement location="/usr/share/java/junit4.jar"/>
+       </path>
+       
+@@ -71,10 +72,8 @@
                        <manifest>
                                <attribute name="Main-Class" value="${main-class}"/>
                                <attribute name="SplashScreen-Image" value="pix/splashscreen.png"/>
@@ -29,7 +45,16 @@ index 394aea4..d420c52 100644
                </jar>
        </target>
        
-@@ -213,4 +214,4 @@ ${nonascii}</fail>
+@@ -90,7 +89,7 @@
+                       <fileset dir="." includes="*">
+                               <type type="file"/>
+                       </fileset>
+-                      <fileset dir="." includes="datafiles/ lib/ lib-test/ pix/ src/ test/"/>
++                      <fileset dir="." includes="datafiles/ pix/ src/ test/"/>
+               </copy>
+               <zip destfile="${dist.src}" basedir="${build.dir}" includes="${pkgname}/"/>
+               <delete dir="${build.dir}/${pkgname}"/>
+@@ -213,4 +212,4 @@ ${nonascii}</fail>
                </echo>
        </target>