initial packaging goo
authorBdale Garbee <bdale@gag.com>
Sat, 13 Mar 2010 22:47:35 +0000 (15:47 -0700)
committerBdale Garbee <bdale@gag.com>
Sat, 13 Mar 2010 22:47:35 +0000 (15:47 -0700)
debian/changelog [new file with mode: 0644]
debian/compat [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/gbp.conf [new file with mode: 0644]
debian/rules [new file with mode: 0755]

diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..70482b9
--- /dev/null
@@ -0,0 +1,5 @@
+openrocket (1.0.0-1) unstable; urgency=low
+
+  * initial packaging for Debian
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 13 Mar 2010 15:25:12 -0700
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..7f8f011
--- /dev/null
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..53ba78d
--- /dev/null
@@ -0,0 +1,19 @@
+Source: openrocket
+Section: science
+Priority: optional
+Maintainer: Bdale Garbee <bdale@gag.com>
+Build-Depends: debhelper (>= 7)
+Standards-Version: 3.8.4
+Homepage: http://openrocket.sourceforge.net/
+
+Package: openrocket
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Model Rocket Simulator
+ OpenRocket is a free, fully featured model rocket simulator that allows 
+ you to design and simulate your rockets before actually building and 
+ flying them.
+
+ OpenRocket features a full six-degree-of-freedom simulation, realistic 
+ wind modeling, a multitude of different components including free-form 
+ and canted fins, clustering and staging. 
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..3479e72
--- /dev/null
@@ -0,0 +1,35 @@
+This work was packaged for Debian by:
+
+    Bdale Garbee <bdale@gag.com> on Sat, 13 Mar 2010 15:25:12 -0700
+
+It was downloaded from:
+
+    http://openrocket.sourceforge.net/
+
+Upstream Author(s):
+
+    Sampo Niskanen <sampo.niskanen@iki.fi>
+
+Copyright:
+
+    Copyright (C) 2007-2010 Sampo Niskanen
+
+License:
+
+    GPL version 3 with additional permission under section 7:
+
+    The licensors grant additional permission to package this Program, or
+    any covered work, along with any non-compilable data files (such as
+    thrust curves or component databases) and convey the resulting work.
+
+The Debian packaging is:
+
+    Copyright (C) 2010 Bdale Garbee <bdale@gag.com>
+
+and is also licensed under the GPL version 3, 
+see "/usr/share/common-licenses/GPL-3".
+
+The source distribution and binary packages also contain rocket motor 
+performance data files from thrustcurve.org.  These carry various copyright 
+assertions, but all are made available for public use with no distribution 
+restrictions.
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..2ccbe7a
--- /dev/null
@@ -0,0 +1,3 @@
+fileformat.txt
+README.TXT
+TODO
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644 (file)
index 0000000..15b1cba
--- /dev/null
@@ -0,0 +1,46 @@
+# Configuration file for git-buildpackage and friends
+
+[DEFAULT]
+# the default build command:
+#builder = debuild -i\.git/ -I.git
+# the default clean command:
+#cleaner = debuild clean
+# the default branch for upstream sources:
+upstream-branch = upstream
+# the default branch for the debian patch:
+debian-branch = debian
+# the default tag formats used:
+#upstream-tag = upstream/%(version)s
+#debian-tag = debian/%(version)s
+# use pristine-tar:
+pristine-tar = True
+
+# Options only affecting git-buildpackage
+[git-buildpackage]
+#upstream-branch = dfsgclean
+# uncomment this to automatically GPG sign tags
+#sign-tags = True
+# keyid to GPG sign tags with
+#keyid = 0xdeadbeef
+# push to a remote repository after a successful tag: 
+posttag = git push --mirror
+# use this for more svn-buildpackage like behaviour:
+export-dir = ../build-area/openrocket/
+#tarball-dir = ../tarballs/
+
+# Options only affecting git-import-orig
+[git-import-orig]
+#upstream-branch = newupstream
+#debian-branch = dfsgclean
+#filter = .svn
+
+# Options only affecting git-import-dsc
+[git-import-dsc]
+#upstream-branch = svn-upstream
+#filter = [ 'CVS', '.cvsignore' ]
+
+# Options only affecting git-dch
+[git-dch]
+#git-log = --no-merges
+#snapshot-number = snapshot + 1
+
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..917d9bf
--- /dev/null
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+%:
+       dh  $@