Imported Debian patch 2.3.1-85 debian/2.3.1-85
authorBdale Garbee <bdale@gag.com>
Sun, 27 Jan 2008 11:18:41 +0000 (00:18 +1300)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 23:24:37 +0000 (17:24 -0600)
MAKEDEV
debian/changelog
debian/control
debian/postinst
debian/preinst

diff --git a/MAKEDEV b/MAKEDEV
index 7a5ffef905a718a33a22217fb03c0042ee0ad393..bc781a82413b22d41ab517fff61a08be9a665b10 100644 (file)
--- a/MAKEDEV
+++ b/MAKEDEV
@@ -31,6 +31,7 @@ scanner="  root root   0666"
    coda="  root root   0600"
   ipsec="  root root   0200"
 readable="  root root   0444"
+   lirc="  root lirc   0640"
 
 MAXVT=63
 
@@ -333,7 +334,7 @@ do
                        hppa)
                                $0 $opts generic-hppa
                                ;;
-                       i386)
+                       i386|lpia)
                                $0 $opts generic-i386
                                ;;
                        amd64)
@@ -1095,7 +1096,7 @@ do
                makedev irnet c 10 187 $system
                ;;
        cbm)
-               makedev irnet c 10 177 $system
+               makedev cbm c 10 177 $system
                ;;
        misc)
                major=`Major mouse 10` || continue
@@ -1683,11 +1684,12 @@ do
                done
                ;;
        pktcdvd)
-               major=97
-               for unit in 0 1 2 3
-               do
-                       makedev pktcdvd$unit b $major $unit $cdrom
-               done
+               echo "pktcdvd major number is now dynamic, taking no action"
+       #       major=97
+       #       for unit in 0 1 2 3
+       #       do
+       #               makedev pktcdvd$unit b $major $unit $cdrom
+       #       done
                ;;
        cfs0)
                makedev cfs0 c 67 0 $coda
@@ -2100,6 +2102,12 @@ do
                    makedev pf$i  b 47 $i $floppy
                done
                 ;;
+        lirc)
+                mknod lirc c 61 0 $lirc
+                for i in d m; do
+                   makedev lirc${i} p $lirc
+                done
+                ;;
        update)
                devices=
                if [ ! -f $procfs/devices ]
index a8aa7e87a4d0a2f798bcdb3c1e04e0d433240ac6..599b953fc38c51de3dd3c144bcb9adaae49f2a58 100644 (file)
@@ -1,3 +1,18 @@
+makedev (2.3.1-85) unstable; urgency=low
+
+  * fix cut'n'paste error in cbm target, closes: #437329
+  * add lirc target, closes: #393575
+  * add support for 'lpia' variant of i386 architecture, closes: #453505
+  * patch to eliminate obsolete init.d conffile from Petter Reinholdtsen,
+    closes: #459677
+  * update postinst to only attempt to make fb if the kernel is Linux, and
+    move chmod of /dev/tty[0-9]* after the forced creation of those devices 
+    so postinst fails less particularly on kfreebsd, closes: #444979, #388270
+  * major number for pktcdvd is now dynamic, don't try to create devices with
+    old/wrong major number, closes: #405819
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 28 Jan 2008 00:18:41 +1300
+
 makedev (2.3.1-84) unstable; urgency=low
 
   * add 'fd' to the list of targets created in the postinst, closes: #394863
index c3bbf9bd58e380743c1dd2f9af4f269381ec2f4f..9a3cf707db9f8d1b17e44e535b96c4ada5b380c6 100644 (file)
@@ -3,7 +3,7 @@ Section: admin
 Priority: required
 Maintainer: Bdale Garbee <bdale@gag.com>
 Build-Depends: debhelper
-Standards-Version: 3.7.2
+Standards-Version: 3.7.3
 
 Package: makedev
 Architecture: all
index 2f269adf6f9edb51e4f64393da5ab426b2dd4b38..d2d8d0aabb8d1d9357c54fd4f0f929a090e480ab 100644 (file)
@@ -16,13 +16,13 @@ fi
 
 /sbin/MAKEDEV std consoleonly fd
 
-/bin/chmod g-r,o= /dev/tty[0-9]*
-
 # ensure base tty set exists, since debootstrap no longer does
 for i in tty0 tty1 tty2 tty3 tty4 tty5 tty6 tty7 tty8 tty9; do
        test -e /dev/$i || /sbin/MAKEDEV $i
 done
 
+/bin/chmod g-r,o= /dev/tty[0-9]*
+
 test -e /dev/random || /sbin/MAKEDEV random
 test -e /dev/urandom || /sbin/MAKEDEV urandom
 test -e /dev/audio || /sbin/MAKEDEV audio
@@ -30,10 +30,10 @@ test -e /dev/agpgart || /sbin/MAKEDEV agpgart
 
 [ ! -f /dev/mouse ] && [ -f /dev/sunmouse ] && ln -s sunmouse mouse
 
-# force update of fb devices if kernel is >= 2.4 and they already exist
+# force update of fb devices if kernel is Linux >= 2.4 and they already exist
 kern_rev1=`uname -r | sed -e 's@^\([^.]*\)\..*@\1@'`
 kern_rev2=`uname -r | sed -e 's@^[^.]*\.\([^.]*\)\..*@\1@'`
-if [ $kern_rev1 -ge 2 ] && [ $kern_rev2 -ge 4 ] && [ -e /dev/fb0 ]
+if [ `uname -s` == "Linux" ] && [ $kern_rev1 -ge 2 ] && [ $kern_rev2 -ge 4 ] && [ -e /dev/fb0 ]
 then
        /sbin/MAKEDEV fb
 fi
index 87ca351cdf7bcb73cee4b857a48cc9e574b67584..4575a58cdb5a9d3a051ca6254bb92d1dfc7811a9 100644 (file)
@@ -1,5 +1,29 @@
 #!/bin/sh
 
+# Remove a no-longer used conffile
+rm_conffile() {
+    PKGNAME="$1"
+    CONFFILE="$2"
+    if [ -e "$CONFFILE" ]; then
+        md5sum="`md5sum \"$CONFFILE\" | sed -e \"s/ .*//\"`"
+        old_md5sum="`dpkg-query -W -f='${Conffiles}' $PKGNAME | sed -n -e \"\\\\' $CONFFILE'{s/ obsolete$//;s/.* //p}\"`"
+        if [ "$md5sum" != "$old_md5sum" ]; then
+            echo "Obsolete conffile $CONFFILE has been modified by you."
+            echo "Saving as $CONFFILE.dpkg-old ..."
+            mv -f "$CONFFILE" "$CONFFILE".dpkg-old
+        else
+            echo "Removing obsolete conffile $CONFFILE ..."
+            rm -f "$CONFFILE"
+        fi
+    fi
+}
+case "$1" in
+install|upgrade)
+    if dpkg --compare-versions "$2" le "2.3.1-85"; then
+        rm_conffile makedev /etc/init.d/makedev
+    fi
+esac
+
 rm -f /usr/man/man8/MAKEDEV.8 /usr/man/man8/MAKEDEV-C.8 \
        /usr/man/man8/MAKEDEV-C.8.gz