Imported Debian patch 2.3.1-77 debian/2.3.1-77
authorBdale Garbee <bdale@gag.com>
Mon, 14 Mar 2005 23:53:32 +0000 (16:53 -0700)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 23:24:32 +0000 (17:24 -0600)
MAKEDEV
debian/README.Debian [deleted file]
debian/changelog
debian/rules

diff --git a/MAKEDEV b/MAKEDEV
index 62d6ee6e59c392286ce84024334f6c3518765836..d9224a445397c94e95e89bb8b728242caafd2deb 100644 (file)
--- a/MAKEDEV
+++ b/MAKEDEV
@@ -44,10 +44,19 @@ major_lp=6
 
 #---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#
 
 
 #---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#
 
-# if udev is running, and we're in /dev, relocate ourselves 
-if [ -d /.dev/ ] && [ "`pwd`" = /dev ] && [ -e /proc/mounts ] \
-   && grep -qE '^[^ ]+ /\.dev' /proc/mounts; then
-       cd /.dev/
+# try to do the right things if udev is running
+if [ "$WRITE_ON_UDEV" ]; then
+  :
+elif [ -d /dev/.static/dev/ ] && [ "`pwd`" = /dev ] && [ -e /proc/mounts ] \
+    && grep -qE '^[^ ]+ /dev/\.static/dev' /proc/mounts; then
+  cd /dev/.static/dev/
+elif [ -d /.dev/ ] && [ "`pwd`" = /dev ] && [ -e /proc/mounts ] \
+    && grep -qE '^[^ ]+ /\.dev' /proc/mounts; then
+  cd /.dev/
+elif [ -d .udevdb/ ] && [ "`pwd`" = /dev ]; then
+  echo ".udevdb presence implies active udev.  Aborting MAKEDEV invocation."
+  # use exit 0, not 1, so postinst scripts don't fail on this
+  exit 0
 fi
 
 #---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#
 fi
 
 #---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#---#
@@ -1045,7 +1054,7 @@ do
                major=`Major $arg 10` || continue
                makedev $arg    c $major 175 $video
                ;;
                major=`Major $arg 10` || continue
                makedev $arg    c $major 175 $video
                ;;
-       hwrandom)
+       hwrng)
                major=`Major $arg 10` || continue
                makedev $arg    c $major 183 $private
                ;;
                major=`Major $arg 10` || continue
                makedev $arg    c $major 183 $private
                ;;
@@ -1128,6 +1137,9 @@ do
        systrace)
                makedev systrace  c 10 226 $private
                ;;
        systrace)
                makedev systrace  c 10 226 $private
                ;;
+       uinput)
+               makedev input/uinput  c 10 223 $mouse
+               ;;
        js)
                major=`Major Joystick 13` || continue
                for unit in 0 1 2 3
        js)
                major=`Major Joystick 13` || continue
                for unit in 0 1 2 3
diff --git a/debian/README.Debian b/debian/README.Debian
deleted file mode 100644 (file)
index f6481f3..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-This version of makedev is not particularly happy on systems running devfs.  
-All bugs regarding devfs interaction will be retained at severity 'wishlist'
-until we figure out what makedev's interaction with devfs should be...
index b98bafe491ff372491356ad7cce2a3bea9fb2455..8c203a7ebaf93552e9cc6fa4876febbc25e09bda 100644 (file)
@@ -1,3 +1,15 @@
+makedev (2.3.1-77) unstable; urgency=medium
+
+  * update udev handling on advice from Marco d'Itri.  Handles more cases
+    and provides the ability to override the avoidance logic if environment
+    variable WRITE_ON_UDEV is set.  Urgency medium to help a new udev upload 
+    depending on this behavior get into sarge.  closes: #264421
+  * change hwrandom to hwrng, closes: #295324
+  * patch from Gaudenz Steinlin to add input/uinput support, closes: #294361
+  * remove README.Debian, since the content is obsolete
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 14 Mar 2005 16:53:32 -0700
+
 makedev (2.3.1-76) unstable; urgency=low
 
   * make ppc64 an alias for powerpc, closes: #282687
 makedev (2.3.1-76) unstable; urgency=low
 
   * make ppc64 an alias for powerpc, closes: #282687
index bde3903b4b10e8c3eebce177ee063ecb53f7282d..10bacb48765bfac36a29c6acb72f2f54b82949c5 100755 (executable)
@@ -30,7 +30,7 @@ binary-indep: build
        dh_installmenu -i
        dh_installinit -i
        dh_installcron -i
        dh_installmenu -i
        dh_installinit -i
        dh_installcron -i
-       dh_installmanpages -i
+       dh_installman -i MAKEDEV.man 
        dh_installchangelogs -i
        dh_strip -i
        dh_compress -i
        dh_installchangelogs -i
        dh_strip -i
        dh_compress -i