Imported Debian patch 2.3.1-81 debian/2.3.1-81
authorBdale Garbee <bdale@gag.com>
Tue, 11 Apr 2006 07:04:34 +0000 (16:04 +0900)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 23:24:34 +0000 (17:24 -0600)
MAKEDEV
debian/changelog
debian/init.d

diff --git a/MAKEDEV b/MAKEDEV
index 6fba12ad1aaca2478557554ff281ed45afa9dfe5..f38f0733664a22ae4a44c808703a030133c3657b 100644 (file)
--- a/MAKEDEV
+++ b/MAKEDEV
@@ -49,12 +49,14 @@ if [ "$WRITE_ON_UDEV" ]; then
   :
 elif [ -d /dev/.static/dev/ ] && [ "`pwd`" = /dev ] && [ -e /proc/mounts ] \
     && grep -qE '^[^ ]+ /dev/\.static/dev' /proc/mounts; then
+  echo "udev active, devices will be created in /dev/.static/dev/"
   cd /dev/.static/dev/
 elif [ -d /.dev/ ] && [ "`pwd`" = /dev ] && [ -e /proc/mounts ] \
     && grep -qE '^[^ ]+ /\.dev' /proc/mounts; then
+  echo "udev active, devices will be created in /.dev/"
   cd /.dev/
 elif [ -d .udevdb/ -o -d .udev/ ] && [ "`pwd`" = /dev ]; then
-  echo ".udevdb presence implies active udev.  Aborting MAKEDEV invocation."
+  echo ".udevdb or .udev presence implies active udev.  Aborting MAKEDEV invocation."
   # use exit 0, not 1, so postinst scripts don't fail on this
   exit 0
 fi
@@ -617,6 +619,12 @@ do
                        makedev scc$unit c 34 $unit $system
                done
                ;;
+       mtd)    
+               for unit in 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
+               do
+                       makedev mtd$unit c 90 `math $unit \* 2` $system
+               done
+               ;;
        bc)     
                for unit in 0 1 2 3
                do
@@ -717,6 +725,10 @@ do
                        makedev video1394/$i c 171 `math 16 + $i` $video
                done
                ;;
+       alsa)
+               echo "You requested 'alsa' devices.  Please install the alsa-base package instead,"
+               echo "which creates and maintains device information for ALSA."
+               ;;
        nvram)
                makedev nvram c 10 144 $mouse
                ;;
@@ -1052,6 +1064,10 @@ do
                major=`Major $arg 10` || continue
                makedev $arg    c $major 183 $private
                ;;
+       mcelog)
+               major=`Major $arg 10` || continue
+               makedev $arg    c $major 227 $private
+               ;;
        cpu|microcode)
                mkdir -p cpu
                makedev cpu/microcode c 10 184 $private
index ea4cca4bec2a39d2cb946481ac1352d93559ea17..f5f802cabb2c4f0d800f7f339aac469498034ce0 100644 (file)
@@ -1,3 +1,15 @@
+makedev (2.3.1-81) unstable; urgency=low
+
+  * add check for /dev/.udev in init.d at Md's request
+  * create an 'alsa' target that suggests installing alsa-base, closes: #261439
+  * add 'mcelog' target, closes: #302047
+  * notify user if udev is detected and we're going to create devices other
+    than in pwd, closes: #313391
+  * add 'mtd' target.  don't add 'mtdblock', since it duplicates the existing
+    'rom' target, closes: #344789
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 11 Apr 2006 16:04:34 +0900
+
 makedev (2.3.1-80) unstable; urgency=low
 
   * make armeb an alias for arm when picking generic target, closes: #333584
index c3a72e20006215b21325f9d73feee1c2e48f7e4d..c047f645d36a1670486140a7f541cbf8a61e6e20 100644 (file)
@@ -16,7 +16,7 @@ case "$1" in
        # recreation of the devices (MAKEDEV dvb checks the kernel-version 
        # and uses the correct major-number))
        
-       if [ ! -e /dev/.devfsd -a ! -e /dev/.udevdb ]; then
+       if [ ! -e /dev/.devfsd -a ! -e /dev/.udevdb -a ! -e /dev/.udev ]; then
                if [ -d /dev/dvb ]; then
                        cd /dev && ./MAKEDEV dvb
                fi