clean up a handful of lintian whines
authorBdale Garbee <bdale@gag.com>
Thu, 30 Jul 2009 15:31:02 +0000 (17:31 +0200)
committerBdale Garbee <bdale@gag.com>
Thu, 30 Jul 2009 15:31:02 +0000 (17:31 +0200)
debian/changelog
debian/compat
debian/control
debian/postinst

index 1fbf9f38a5760e6db6b778259e9d1c5678044ae9..844ba4c2a0e17d49da6805818a5be57b4651e200 100644 (file)
@@ -2,6 +2,8 @@ makedev (2.3.1-89) UNRELEASED; urgency=low
 
   * move to priority extra, closes: #522048
   * use dpkg --print-architecture instead of deprecated form, closes: #536540
+  * eliminate explicit use of path for MAKEDEV calls in postinst
+  * update standards and debhelper version dependencies
 
  -- Bdale Garbee <bdale@gag.com>  Thu, 30 Jul 2009 13:31:20 +0200
 
index b8626c4cff2849624fb67f87cd0ad72b163671ad..7ed6ff82de6bcc2a78243fc9c54d3ef5ac14da69 100644 (file)
@@ -1 +1 @@
-4
+5
index b049099d2b5b694ca98a3fbc31458335e2acd494..9f6904a2d65570adb30537116b0bfacc9800d181 100644 (file)
@@ -2,7 +2,7 @@ Source: makedev
 Section: admin
 Priority: extra
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper
+Build-Depends: debhelper (>= 5)
 Standards-Version: 3.8.2
 
 Package: makedev
index 9cb70cd5abba45ebcbff7929fec5fd9a808d86ac..f6bbd4cf80c527f766ae65e00c255bb94b44de74 100644 (file)
@@ -14,19 +14,19 @@ then
     exit 0
 fi
 
-/sbin/MAKEDEV std consoleonly fd
+MAKEDEV std consoleonly fd
 
 # ensure base tty set exists, since debootstrap no longer does
 for i in tty0 tty1 tty2 tty3 tty4 tty5 tty6 tty7 tty8 tty9; do
-       test -e /dev/$i || /sbin/MAKEDEV $i
+       test -e /dev/$i || MAKEDEV $i
 done
 
-/bin/chmod g-r,o= /dev/tty[0-9]*
+chmod g-r,o= /dev/tty[0-9]*
 
-test -e /dev/random || /sbin/MAKEDEV random
-test -e /dev/urandom || /sbin/MAKEDEV urandom
-test -e /dev/audio || /sbin/MAKEDEV audio
-test -e /dev/agpgart || /sbin/MAKEDEV agpgart
+test -e /dev/random || MAKEDEV random
+test -e /dev/urandom || MAKEDEV urandom
+test -e /dev/audio || MAKEDEV audio
+test -e /dev/agpgart || MAKEDEV agpgart
 
 [ ! -f /dev/mouse ] && [ -f /dev/sunmouse ] && ln -s sunmouse mouse
 
@@ -35,7 +35,7 @@ kern_rev1=`uname -r | sed -e 's@^\([^.]*\)\..*@\1@'`
 kern_rev2=`uname -r | sed -e 's@^[^.]*\.\([^.]*\)\..*@\1@'`
 if [ `uname -s` = "Linux" ] && [ $kern_rev1 -ge 2 ] && [ $kern_rev2 -ge 4 ] && [ -e /dev/fb0 ]
 then
-       /sbin/MAKEDEV fb
+       MAKEDEV fb
 fi
 
 for A in sda16 sdb16 sdc16 sdd16 sde16 sdf16 sdg16 sdh16 \
@@ -58,7 +58,7 @@ LIST=""
 for TYPE in tty pty ; do
        for LETTER in p q r s t u v w x y z a b c d e ; do
                if [ -e /dev/$TYPE$LETTER"0" ]; then
-                       MAJOR="`/bin/ls -l /dev/$TYPE$LETTER"0"|cut -c33-36`"
+                       MAJOR="`ls -l /dev/$TYPE$LETTER"0"|cut -c33-36`"
                        if [ "$MAJOR" = 4 ] ; then
                                LIST="$LIST $TYPE$LETTER"
                        fi
@@ -71,7 +71,7 @@ if [ -n "$LIST" ]; then
 #!/bin/sh
 
 echo "Creating new console devices"
-/sbin/MAKEDEV $LIST
+MAKEDEV $LIST
 
 rm /etc/rc.boot/makedev ; exit 0
 EOF