Imported Debian patch 2.3.1-79 debian/2.3.1-79
authorBdale Garbee <bdale@gag.com>
Thu, 6 Oct 2005 22:57:12 +0000 (15:57 -0700)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 23:24:33 +0000 (17:24 -0600)
MAKEDEV
debian/changelog
debian/compat [new file with mode: 0644]
debian/conffiles [deleted file]
debian/control
debian/init.d
debian/rules

diff --git a/MAKEDEV b/MAKEDEV
index 6945934b9e5b08b91b662e3ff93a514daccc60cb..1f15cd12501b4bcaecc73eec15f8ff89e8459e87 100644 (file)
--- a/MAKEDEV
+++ b/MAKEDEV
@@ -225,7 +225,7 @@ cvt () {
        do
                case "$1" in
                        mem|tty|ttyp|cua|cub|cui)       ;;
-                       hd)     (for d in a b c d e f g h ; do
+                       hd)     (for d in a b c d e f g h i j k l m n o p ; do
                                        echo -n hd$d " "
                                 done) ; echo
                                ;;
@@ -239,7 +239,10 @@ cvt () {
                        ide7)   echo hdo hdp ;;
                        ide8)   echo hdq hdr ;;
                        ide9)   echo hds hdt ;;
-                       sd)     echo sda sdb sdc sdd ;;
+                       sd)     (for d in a b c d e f g h i j k l m n o p ; do
+                                       echo -n sd$d " "
+                                done) ; echo
+                               ;;
                        dasd)   (for d in a b c d e f g h i j k l m \
                                        n o p q r s t u v w x y z ; do
                                        echo -n dasd$d " "
@@ -302,15 +305,17 @@ cvt () {
                        bluetooth)      echo bluetooth ;;
                        lvm)    ;; # taken care of by LVM userspace tools
                        ramdisk)        echo ram ;;
-                       *)      echo "$0: don't know what \"$1\" is" >&2 ;;
+                       null)   echo std ;;
+                       zero)   echo std ;;
+#                      *)      echo "$0: don't know what \"$1\" is" >&2 ;;
+                       *)      echo $1
                esac
                shift
        done
 }
 
-for arg in $*
+for arg in `cvt $*`
 do
-#      case `cvt $arg` in
        case $arg in
        generic)
                # pick the right generic-<arch> using dpkg's knowledge
@@ -367,9 +372,8 @@ do
                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
-               $0 $opts hda hdb hdc hdd
+               $0 $opts hd sd
                $0 $opts xda xdb
-               $0 $opts sda sdb sdc sdd
                $0 $opts scd0 scd1
                $0 $opts st0 st1
                $0 $opts sg
@@ -387,9 +391,8 @@ do
                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
-               $0 $opts hda hdb hdc hdd
+               $0 $opts hd sd
                $0 $opts xda xdb
-               $0 $opts sda sdb sdc sdd
                $0 $opts scd0 scd1
                $0 $opts st0 st1
                $0 $opts sg
@@ -407,8 +410,7 @@ do
                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
-               $0 $opts hda hdb hdc hdd
-               $0 $opts sda sdb sdc sdd
+               $0 $opts hd sd
                $0 $opts scd0 scd1
                $0 $opts st0 st1
                $0 $opts sg
@@ -427,9 +429,8 @@ do
                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
-               $0 $opts hda hdb hdc hdd
+               $0 $opts hd sd
                $0 $opts xda xdb
-               $0 $opts sda sdb sdc sdd
                $0 $opts scd0 scd1
                $0 $opts st0 st1
                $0 $opts sg
@@ -451,8 +452,7 @@ do
                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
-               $0 $opts hda hdb hdc hdd
-               $0 $opts sda sdb sdc sdd
+               $0 $opts hd sd
                $0 $opts scd0 scd1
                $0 $opts st0 st1
                $0 $opts sg
@@ -471,8 +471,7 @@ do
                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
-               $0 $opts hda hdb hdc hdd
-               $0 $opts sda sdb sdc sdd
+               $0 $opts hd sd
                $0 $opts scd0 scd1
                $0 $opts sg
                $0 $opts ada adb adc add ade adf
@@ -490,8 +489,7 @@ do
                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
-               $0 $opts hda hdb
-               $0 $opts sda sdb sdc sdd
+               $0 $opts hd sd
                $0 $opts scd0 scd1
                $0 $opts st0 st1
                $0 $opts sg
@@ -508,8 +506,7 @@ do
                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
-               $0 $opts hda hdb
-               $0 $opts sda sdb sdc sdd
+               $0 $opts hd sd
                $0 $opts scd0 scd1
                $0 $opts st0 st1
                $0 $opts sg
@@ -526,8 +523,7 @@ do
                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
-               $0 $opts hda hdb hdc hdd
-               $0 $opts sda sdb sdc sdd
+               $0 $opts hd sd
                $0 $opts scd0 scd1
                $0 $opts st0 st1
                $0 $opts sg
@@ -561,8 +557,7 @@ do
                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
-               $0 $opts hda hdb
-               $0 $opts sda sdb sdc sdd
+               $0 $opts hd sd
                $0 $opts scd0 scd1
                $0 $opts st0 st1
                $0 $opts sg
@@ -580,8 +575,7 @@ do
                $0 $opts std
                $0 $opts fd
                $0 $opts fd0 fd1
-               $0 $opts hda hdb hdc hdd
-               $0 $opts sda sdb sdc sdd
+               $0 $opts hd sd
                $0 $opts scd0 scd1
                $0 $opts st0 st1
                $0 $opts sg
@@ -1207,7 +1201,7 @@ do
                base=`index ab $unit`
                base=`math $base \* 64`
                makedev hd$unit b $major $base $disk
-               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
+               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
                do
                        makedev hd$unit$part b $major `math $base + $part` $disk
                done
@@ -1218,7 +1212,7 @@ do
                base=`index cd $unit`
                base=`math $base \* 64`
                makedev hd$unit b $major $base $disk
-               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
+               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
                do
                        makedev hd$unit$part b $major $(( $base + $part )) $disk
                done
@@ -1229,7 +1223,7 @@ do
                base=`index ef $unit`
                base=`math $base \* 64`
                makedev hd$unit b $major $base $disk
-               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
+               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
                do
                        makedev hd$unit$part b $major $(( $base + $part )) $disk
                done
@@ -1240,7 +1234,7 @@ do
                base=`index gh $unit`
                base=`math $base \* 64`
                makedev hd$unit b $major $base $disk
-               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
+               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
                do
                        makedev hd$unit$part b $major $(( $base + $part )) $disk
                done
@@ -1251,7 +1245,7 @@ do
                base=`index ij $unit`
                base=`math $base \* 64`
                makedev hd$unit b $major $base $disk
-               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
+               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
                do
                        makedev hd$unit$part b $major $(( $base + $part )) $disk
                done
@@ -1262,7 +1256,7 @@ do
                base=`index kl $unit`
                base=`math $base \* 64`
                makedev hd$unit b $major $base $disk
-               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
+               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
                do
                        makedev hd$unit$part b $major $(( $base + $part )) $disk
                done
@@ -1273,7 +1267,7 @@ do
                base=`index mn $unit`
                base=`math $base \* 64`
                makedev hd$unit b $major $base $disk
-               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
+               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
                do
                        makedev hd$unit$part b $major $(( $base + $part )) $disk
                done
@@ -1284,7 +1278,7 @@ do
                base=`index op $unit`
                base=`math $base \* 64`
                makedev hd$unit b $major $base $disk
-               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
+               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
                do
                        makedev hd$unit$part b $major $(( $base + $part )) $disk
                done
@@ -1295,7 +1289,7 @@ do
                base=`index qr $unit`
                base=`math $base \* 64`
                makedev hd$unit b $major $base $disk
-               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
+               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
                do
                        makedev hd$unit$part b $major $(( $base + $part )) $disk
                done
@@ -1306,7 +1300,7 @@ do
                base=`index st $unit`
                base=`math $base \* 64`
                makedev hd$unit b $major $base $disk
-               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
+               for part in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
                do
                        makedev hd$unit$part b $major $(( $base + $part )) $disk
                done
index a94e71136963c941f9567345768c2c456660356f..ef9df3de5545194b4faa69a2090a98eeb36f7402 100644 (file)
@@ -1,3 +1,18 @@
+makedev (2.3.1-79) unstable; urgency=low
+
+  * have init script recognize udev as well as devfs, closes: #326083
+  * change 'hd' and 'sd' targets to create 16 drives worth of devices by
+    default, closes: #330218, #288129, #301367, #311678
+  * change 'hd' to create 24 partitions by default, closes: #300913
+  * change generic targets to use 'hd' and 'sd' instead of different numbers
+    of drives by default
+  * call cvt() function on all arguments, and have cvt() behave transparently
+    if handed a target that isn't a macro
+  * map null and zero to std in cvt(), closes: #296225, #296296
+  * move to debhelper compat level 4
+
+ -- Bdale Garbee <bdale@gag.com>  Thu,  6 Oct 2005 15:57:12 -0700
+
 makedev (2.3.1-78) unstable; urgency=medium
 
   * update postinst syntax for chown call to owner:group, closes: #300791
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..b8626c4
--- /dev/null
@@ -0,0 +1 @@
+4
diff --git a/debian/conffiles b/debian/conffiles
deleted file mode 100644 (file)
index 0a2613e..0000000
+++ /dev/null
@@ -1 +0,0 @@
-/etc/init.d/makedev
index 2ac2b7297df1b97afaa601ac450e821155a7839c..1b2d0186f9b3e88c595228b889a2002cebddac8e 100644 (file)
@@ -3,7 +3,7 @@ Section: base
 Priority: required
 Maintainer: Bdale Garbee <bdale@gag.com>
 Build-Depends-Indep: debhelper
-Standards-Version: 3.6.1.1
+Standards-Version: 3.6.2.1
 
 Package: makedev
 Architecture: all
index c3f1dec0222de46c921584540b70c0bb9a8b4fc9..c3a72e20006215b21325f9d73feee1c2e48f7e4d 100644 (file)
@@ -10,13 +10,13 @@ case "$1" in
        test -L /dev/MAKEDEV || ln -fs /sbin/MAKEDEV /dev/MAKEDEV
 
        # create dvb-devices, if the dvb-directory allready exists, and 
-       # no devfs is used (this a workaround for the changed major-number
+       # no devfs or udev is in use (workaround for the changed major-number
        # of the dvb-devices, introduced in kernel 2.6.8, to be able to 
        # switch between kernels <= 2.6.7 and >= 2.6.8, without manual 
        # recreation of the devices (MAKEDEV dvb checks the kernel-version 
        # and uses the correct major-number))
        
-       if [ ! -e /dev/.devfsd ]; then
+       if [ ! -e /dev/.devfsd -a ! -e /dev/.udevdb ]; then
                if [ -d /dev/dvb ]; then
                        cd /dev && ./MAKEDEV dvb
                fi
index 10bacb48765bfac36a29c6acb72f2f54b82949c5..fa0ddf1e68e8591875beb944b7f4b141b9ce4630 100755 (executable)
@@ -23,7 +23,7 @@ binary-indep: build
        dh_testroot -i
        dh_installdirs -i
 
-       ROOT=debian/tmp $(MAKE) install 
+       ROOT=debian/makedev $(MAKE) install 
 
        dh_installdocs  -i
        dh_installexamples -i