instead of patching lib/Makefile.in directly, try autoreconf in rules
authorBdale Garbee <bdale@gag.com>
Mon, 21 Feb 2011 17:58:35 +0000 (10:58 -0700)
committerBdale Garbee <bdale@gag.com>
Mon, 21 Feb 2011 17:58:35 +0000 (10:58 -0700)
debian/patches/getdtablesize-missing.diff
debian/rules

index 9852a62797ea41eaf746f318d37b2a7277942f61..b6e3ba1fa5a150b78ca6d4f84ba082f92d18cc4e 100644 (file)
@@ -67,35 +67,6 @@ index 0000000..a565a2d
 +}
 +
 +#endif
-diff --git a/lib/Makefile.in b/lib/Makefile.in
-index 1b42ddb..d71b78f 100644
---- a/lib/Makefile.in
-+++ b/lib/Makefile.in
-@@ -95,6 +95,7 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/00gnulib.m4 \
-       $(top_srcdir)/m4/ftello.m4 \
-       $(top_srcdir)/m4/getcwd-abort-bug.m4 \
-       $(top_srcdir)/m4/getcwd-path-max.m4 $(top_srcdir)/m4/getcwd.m4 \
-+      $(top_srcdir)/m4/getdtablesize.m4 \
-       $(top_srcdir)/m4/getopt.m4 $(top_srcdir)/m4/gettime.m4 \
-       $(top_srcdir)/m4/gettimeofday.m4 $(top_srcdir)/m4/glibc21.m4 \
-       $(top_srcdir)/m4/gnu-make.m4 $(top_srcdir)/m4/gnulib-common.m4 \
-@@ -901,7 +902,7 @@ EXTRA_DIST = alloca.in.h $(top_srcdir)/build-aux/announce-gen \
-       fpucw.h fpurge.c stdio-impl.h freadahead.h stdio-impl.h \
-       freading.h stdio-impl.h frexp.c frexp.c frexpl.c fseeko.c \
-       stdio-impl.h fseterr.h stdio-impl.h ftello.c \
--      $(top_srcdir)/build-aux/gendocs.sh getcwd.c getopt.c \
-+      $(top_srcdir)/build-aux/gendocs.sh getcwd.c getopt.c getdtablesize.c \
-       getopt.in.h getopt1.c getopt_int.h gettime.c gettimeofday.c \
-       $(top_srcdir)/build-aux/git-version-gen \
-       $(top_srcdir)/build-aux/gitlog-to-changelog \
-@@ -975,6 +976,7 @@ EXTRA_libgzip_a_SOURCES = calloc.c calloc.c chdir-long.c chown.c \
-       error.c exitfail.c fchdir.c fclose.c fcntl.c creat-safer.c \
-       open-safer.c fdopendir.c openat-proc.c fflush.c fpending.c \
-       fprintf.c fpurge.c frexp.c frexp.c frexpl.c fseeko.c ftello.c \
-+      getdtablesize.c \
-       getcwd.c getopt.c getopt1.c gettime.c gettimeofday.c isnan.c \
-       isnand.c isnan.c isnanf.c isnan.c isnanl.c lchown.c lseek.c \
-       lstat.c malloc.c malloc.c mbrtowc.c mbsinit.c memchr.c \
 diff --git a/gzip/m4/getdtablesize.m4 b/gzip/m4/getdtablesize.m4
 new file mode 100644
 index 0000000..d238628
index 8369833fffec22688eaf796561e0c076083d9525..63585194c718e9f17393605e7c7a6f07505dde07 100755 (executable)
@@ -23,6 +23,7 @@ configure-stamp:
        dh_testdir
        cp -f /usr/share/misc/config.sub build-aux/config.sub
        cp -f /usr/share/misc/config.guess build-aux/config.guess
+       autoreconf -v
        mkdir -p build
        cd build && ../configure \
                --prefix=/usr --bindir=/bin \