tests: exercise the new --keep option
authorJim Meyering <meyering@fb.com>
Sun, 26 May 2013 18:52:17 +0000 (11:52 -0700)
committerJim Meyering <meyering@fb.com>
Tue, 28 May 2013 13:25:42 +0000 (06:25 -0700)
* tests/keep: New file.
* tests/Makefile.am (TESTS): Add it.

tests/Makefile.am
tests/keep [new file with mode: 0755]

index ad0860167f6803696257ea646dab0fd72871be83..53bfffa19021774a2740621129595e26c88483b6 100644 (file)
@@ -18,6 +18,7 @@ TESTS =                                       \
   helin-segv                           \
   help-version                         \
   hufts                                        \
+  keep                                 \
   memcpy-abuse                         \
   mixed                                        \
   null-suffix-clobber                  \
diff --git a/tests/keep b/tests/keep
new file mode 100755 (executable)
index 0000000..b2bbcd3
--- /dev/null
@@ -0,0 +1,44 @@
+#!/bin/sh
+# Exercise the --keep option.
+
+# Copyright (C) 2013 Free Software Foundation, Inc.
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+# limit so don't run it by default.
+
+. "${srcdir=.}/init.sh"; path_prepend_ ..
+
+echo fooooooooo > in || framework_failure_
+cp in orig || framework_failure_
+
+fail=0
+
+# Compress and decompress both with and without --keep.
+for k in --keep ''; do
+  # With --keep, the source must be retained, otherwise, it must be removed.
+  case $k in --keep) op='||' ;; *) op='&&' ;; esac
+
+  gzip $k in || fail=1
+  eval "test -f in $op fail=1"
+  test -f in.gz || fail=1
+  rm -f in || fail=1
+
+  gzip -d $k in.gz || fail=1
+  eval "test -f in.gz $op fail=1"
+  test -f in || fail=1
+  compare in orig || fail=1
+  rm -f in.gz || fail=1
+done
+
+Exit $fail