build using mingw-w64 instead of mingw32
authorBdale Garbee <bdale@gag.com>
Wed, 20 Apr 2011 07:49:17 +0000 (01:49 -0600)
committerBdale Garbee <bdale@gag.com>
Wed, 20 Apr 2011 07:49:17 +0000 (01:49 -0600)
debian/changelog
debian/control
debian/rules

index 57b31f7d3db860e89dcda3d974f9352af0b1d750..3f27cea7cf8836f73415428d0a3b222c798fe6c7 100644 (file)
@@ -4,8 +4,9 @@ gzip (1.4-1) UNRELEASED; urgency=low
   * add Vcs entries to control file
   * patch zless LESSOPEN definition to allow handling of gunzip data on STDIN,
     closes: #248302
+  * Build using mingw-w64 instead of mingw32, closes: #623428
 
- -- Bdale Garbee <bdale@gag.com>  Sun, 20 Feb 2011 21:59:46 -0700
+ -- Bdale Garbee <bdale@gag.com>  Wed, 20 Apr 2011 01:48:46 -0600
 
 gzip (1.3.12-9) unstable; urgency=high
 
index 9397d1352129824570f9d998575b199578926d9b..53521ba1ce2b82c26cfee9e756fd30f3c221d719 100644 (file)
@@ -4,7 +4,7 @@ Priority: required
 Maintainer: Bdale Garbee <bdale@gag.com>
 Uploaders: Carl Worth <cworth@cworth.org>
 Build-Depends: debhelper (>= 5), texinfo, autoconf, automake, autotools-dev
-Build-Depends-Indep: mingw32
+Build-Depends-Indep: mingw-w64
 Standards-Version: 3.8.0
 Vcs-Git: git://git.gag.com/debian/gzip
 Vcs-Browser: http://git.gag.com/?p=debian/gzip
index 355dc0756a3f1f3effa703e3216c58547c73823f..38c7bf02b676dc142d4b3a66627968b3795005cd 100755 (executable)
@@ -37,7 +37,7 @@ configure-win32: configure-win32-stamp
 configure-win32-stamp: reconf-stamp
        dh_testdir
        mkdir -p build-win32
-       cd build-win32 && ../configure --host=i586-mingw32msvc
+       cd build-win32 && ../configure --host=i686-w64-mingw32
        touch configure-win32-stamp
 
 build: build-stamp 
@@ -71,7 +71,7 @@ install-win32: build-win32
        dh_testroot
        dh_clean -k
        dh_installdirs
-       i586-mingw32msvc-strip build-win32/gzip.exe
+       i686-w64-mingw32-strip build-win32/gzip.exe
        install -m 0755 build-win32/gzip.exe debian/gzip-win32/usr/share/win32/
 
 binary-indep:  build-win32 install-win32