maint: avoid false positive match in check for double semicolon
authorJim Meyering <meyering@fb.com>
Mon, 10 Nov 2014 15:46:47 +0000 (07:46 -0800)
committerJim Meyering <meyering@fb.com>
Mon, 10 Nov 2014 15:46:47 +0000 (07:46 -0800)
* cfg.mk (exclude_file_name_regexp--sc_prohibit_double_semicolon):
Exempt the file, lib/match.c, from gnulib's new double-semicolon
check.

cfg.mk

diff --git a/cfg.mk b/cfg.mk
index 4295fc6e6799253135352acae47fbcf3dc46c58a..b2dc613ea603f326f3e39357de421e699335d91a 100644 (file)
--- a/cfg.mk
+++ b/cfg.mk
@@ -76,6 +76,8 @@ exclude_file_name_regexp--sc_prohibit_empty_lines_at_EOF = \
 exclude_file_name_regexp--sc_prohibit_strcmp = ^gzip\.c$$
 exclude_file_name_regexp--sc_prohibit_always-defined_macros = ^tailor\.h$$
 
+exclude_file_name_regexp--sc_prohibit_double_semicolon = ^lib/match\.c$$
+
 # Tell the tight_scope rule that sources are in ".".
 export _gl_TS_dir = .