fix for #644785
authorBdale Garbee <bdale@gag.com>
Tue, 1 Nov 2011 21:02:08 +0000 (15:02 -0600)
committerBdale Garbee <bdale@gag.com>
Tue, 1 Nov 2011 21:02:08 +0000 (15:02 -0600)
debian/changelog
debian/rules

index 266e0d1debe73c5492935879db20b49a9ac3de44..61d9b5ed9a19ab02f44c56cb58eca0744354d5e7 100644 (file)
@@ -1,3 +1,9 @@
+gzip (1.4-2) UNRELEASED; urgency=low
+
+  * patch to use DEB_HOST_ARCH in rules, closes: #644785
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 01 Nov 2011 15:01:55 -0600
+
 gzip (1.4-1) unstable; urgency=low
 
   * new upstream version, closes: #627121, #633927
index 3361d69b68bfc5ee15054f59731d10bd503449e5..3f9891e0ab9d746975a959d5a51ad69bb4731e4a 100755 (executable)
@@ -11,8 +11,7 @@ ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
 CONFARGS = --host=$(DEB_HOST_GNU_TYPE)
 endif
 
-buildarch := $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-ifeq ($(buildarch),amd64)
+ifeq ($(shell dpkg-architecture -qDEB_HOST_ARCH),amd64)
 CFLAGS=-g -O2 -Wall -DUNALIGNED_OK
 else
 CFLAGS=-g -O2 -Wall