should include the actual patch and debian/changelog entry, too
authorBdale Garbee <bdale@gag.com>
Sat, 10 Aug 2013 20:48:20 +0000 (22:48 +0200)
committerBdale Garbee <bdale@gag.com>
Sat, 10 Aug 2013 20:48:20 +0000 (22:48 +0200)
debian/changelog
debian/patches/gnulib-mingw-w64.diff [new file with mode: 0644]

index 69c2cf7cf6c8ae157ef1824fff8eaf9d4b99708c..edae13408b686379e6672f15c7d5f4086206a6d7 100644 (file)
@@ -1,3 +1,9 @@
+gzip (1.6-2) UNRELEASED; urgency=low
+
+  * patch to update included gnulib for mingw-w64 changes, closes: #713950
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 10 Aug 2013 22:47:47 +0200
+
 gzip (1.6-1) unstable; urgency=low
 
   * new upstream version, closes: #704689, #690583, #521432, #96195, #693463
diff --git a/debian/patches/gnulib-mingw-w64.diff b/debian/patches/gnulib-mingw-w64.diff
new file mode 100644 (file)
index 0000000..ce7b176
--- /dev/null
@@ -0,0 +1,35 @@
+Description: Use __cdecl instead of cdecl
+Author: Paul Eggert <eggert@cs.ucla.edu>
+Origin: http://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=commitdiff;h=86725346a1b116f3c2da26c124288f5f4495bf69
+
+diff --git a/lib/msvc-inval.c b/lib/msvc-inval.c
+index ef2b860..1873e23 100644
+--- a/lib/msvc-inval.c
++++ b/lib/msvc-inval.c
+@@ -28,7 +28,7 @@
+ # if MSVC_INVALID_PARAMETER_HANDLING == DEFAULT_HANDLING
+-static void cdecl
++static void __cdecl
+ gl_msvc_invalid_parameter_handler (const wchar_t *expression,
+                                    const wchar_t *function,
+                                    const wchar_t *file,
+@@ -45,7 +45,7 @@ gl_msvc_invalid_parameter_handler (const wchar_t *expression,
+ #  if defined _MSC_VER
+-static void cdecl
++static void __cdecl
+ gl_msvc_invalid_parameter_handler (const wchar_t *expression,
+                                    const wchar_t *function,
+                                    const wchar_t *file,
+@@ -94,7 +94,7 @@ gl_msvc_inval_current (void)
+     }
+ }
+-static void cdecl
++static void __cdecl
+ gl_msvc_invalid_parameter_handler (const wchar_t *expression,
+                                    const wchar_t *function,
+                                    const wchar_t *file,