maint: dist-check.mk: remove .deps dirs before comparing
authorJim Meyering <meyering@fb.com>
Mon, 29 Feb 2016 03:48:38 +0000 (19:48 -0800)
committerJim Meyering <meyering@fb.com>
Mon, 29 Feb 2016 05:28:14 +0000 (21:28 -0800)
"make distcheck" with automake-from-trunk would fail like this:
  ...
  Only in /gz/tests/torture/gzip/test/gzip-1.6.42-9d47.old: .deps
  Only in /gz/tests/torture/gzip/test/gzip-1.6.42-9d47.old/lib: .deps
  Only in /gz/tests/torture/gzip/test/gzip-1.6.42-9d47.old/lib/glthread: .deps
* dist-check.mk (my-distcheck): Remove all .deps directories before
comparing the two hierarchies.

dist-check.mk

index 6287dfeee1aa3daba0112cc5ce051718229bc646..f23339ebb8444fcafb20c2d43362f35a48124dbe 100644 (file)
@@ -188,6 +188,7 @@ my-distcheck: $(DIST_ARCHIVES) $(local-check)
        )
        (cd $(t) && mv $(distdir) $(distdir).old        \
          && $(amtar_extract_) - ) < $(preferred_tarball_)
+       find $(t)/$(distdir).old $(t)/$(distdir) -name .deps | xargs rmdir
        diff -ur $(t)/$(distdir).old $(t)/$(distdir)
        -rm -rf $(t)
        rmdir $(tmpdir)/$(PACKAGE) $(tmpdir)