gzip: also honor GZIP=--rsyncable
authorJim Meyering <meyering@fb.com>
Thu, 24 Mar 2016 16:06:18 +0000 (09:06 -0700)
committerJim Meyering <meyering@fb.com>
Thu, 24 Mar 2016 16:18:47 +0000 (09:18 -0700)
* gzip.c (main): Also accept --rsyncable when it is specified
via the GZIP environment variable.
I noticed this when gzip's "make dist" failed because maint.mk
detected that gzip now honors --rsyncable, yet when it set GZIP_ENV
to include that, and that propagated via automake-generated code
to the GZIP setting used in the "make dist" rule, there, it was not
honored, and caused "make dist" to fail.

gzip.c

diff --git a/gzip.c b/gzip.c
index 61b19fb0038ed0402b441467115326502e0fc5b9..d66530a70bdce1d19a2687658e9ef0b9f19a1e18 100644 (file)
--- a/gzip.c
+++ b/gzip.c
@@ -560,6 +560,7 @@ int main (int argc, char **argv)
             break;
 
         case RSYNCABLE_OPTION:
+        case RSYNCABLE_OPTION + ENV_OPTION:
             rsync = 1;
             break;
         case 'S':