maint: fix gzip-specific syntax-check rule
authorJim Meyering <meyering@fb.com>
Tue, 30 Aug 2016 03:28:48 +0000 (20:28 -0700)
committerJim Meyering <meyering@fb.com>
Tue, 30 Aug 2016 03:28:48 +0000 (20:28 -0700)
* cfg.mk (sc_gzip_copyright_check): This rule had two problems.
It was failing erroneously (the copyright date in gzip.c is fine),
yet it was complaining.  The first problem is that the rule's
diagnostic mentioned the wrong file: lib/version-etc.c, rather than
./gzip.c. The second problem is that it specified this file name
via "in_files" rather than the "in_vc_files" variable.

cfg.mk

diff --git a/cfg.mk b/cfg.mk
index 8730ed190fd3115339f7cc4ff849e76a0b9deae8..fd287f2a9e1a17f1268e9e26f2918dac5980aae1 100644 (file)
--- a/cfg.mk
+++ b/cfg.mk
@@ -62,8 +62,8 @@ sc_prohibit_emacs__indent_tabs_mode__setting:
 
 sc_gzip_copyright_check:
        @require='Copyright \(C\) '$$(date +%Y)' Free'                  \
-       in_files=$(srcdir)/gzip.c                                       \
-       halt='out of date copyright in $(v_etc_file); update it'        \
+       in_vc_files=$(srcdir)/gzip.c                                    \
+       halt="out of date copyright in $$in_files; update it"           \
          $(_sc_search_regexp)
 
 include $(srcdir)/dist-check.mk