build: avoid warning about deprecated use of automake's ACLOCAL_AMFLAGS
authorJim Meyering <meyering@fb.com>
Sun, 9 Jun 2013 22:28:28 +0000 (15:28 -0700)
committerJim Meyering <meyering@fb.com>
Sun, 9 Jun 2013 22:28:39 +0000 (15:28 -0700)
* Makefile.am (ACLOCAL_AMFLAGS): Don't use this deprecated variable.
* configure.ac: Do this instead: AC_CONFIG_MACRO_DIR([m4]).

Makefile.am
configure.ac

index 764c782f1a559c74f3a71925bd9639b802ea28c7..a3fade7d75b993586b0906ddc2226d0cd74d7b26 100644 (file)
@@ -21,7 +21,6 @@ ALL_RECURSIVE_TARGETS =
 BUILT_SOURCES =
 
 SUBDIRS = lib doc . tests
-ACLOCAL_AMFLAGS = -I m4
 AM_CPPFLAGS = -I$(top_srcdir)/lib
 AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
index cb04125957c9d990830535e9c09d49d1b24be8f1..b2b5d0ace1512564a28a8864497c36020b584424 100644 (file)
@@ -24,8 +24,9 @@ AC_INIT([gzip],
         m4_esyscmd([build-aux/git-version-gen .tarball-version]),
         [bug-gzip@gnu.org])
 
-AC_CONFIG_SRCDIR(gzip.c)
-AC_CONFIG_AUX_DIR(build-aux)
+AC_CONFIG_SRCDIR([gzip.c])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_MACRO_DIR([m4])
 AC_CONFIG_HEADERS([lib/config.h:lib/config.hin])
 AM_INIT_AUTOMAKE([1.11 dist-xz color-tests parallel-tests])
 AM_SILENT_RULES([yes]) # make --enable-silent-rules the default.