maint: don't ignore gitlog-to-changelog failure
authorJim Meyering <meyering@fb.com>
Tue, 15 Mar 2016 17:40:08 +0000 (10:40 -0700)
committerJim Meyering <meyering@fb.com>
Tue, 15 Mar 2016 17:40:08 +0000 (10:40 -0700)
* Makefile.am (gen-ChangeLog): Don't ignore failure of
gitlog-to-changelog. This syncs to coreutils' copy of this rule.

Makefile.am

index dfed9aac09f3e47f76b60cebfd8073ac7f65b54d..e892cdc8bbde3a6b0efa76436fe423f50010677d 100644 (file)
@@ -98,9 +98,9 @@ gen_start_date = 2008-01-01
 gen-ChangeLog:
        $(AM_V_GEN)if test -d .git; then                                \
          $(top_srcdir)/build-aux/gitlog-to-changelog                   \
-           --since=$(gen_start_date) > $(distdir)/cl-t;                \
-         rm -f $(distdir)/ChangeLog;                                   \
-         mv $(distdir)/cl-t $(distdir)/ChangeLog;                      \
+           --since=$(gen_start_date) > $(distdir)/cl-t &&              \
+           { rm -f $(distdir)/ChangeLog &&                             \
+             mv $(distdir)/cl-t $(distdir)/ChangeLog; }                \
        fi
 
 # Prepend "." to $PATH: