Import Debian changes 1.9-2.2 debian/1.9-2.2
authorNiels Thykier <niels@thykier.net>
Fri, 28 Dec 2018 14:34:28 +0000 (14:34 +0000)
committerBdale Garbee <bdale@gag.com>
Sat, 5 Jan 2019 22:57:22 +0000 (15:57 -0700)
gzip (1.9-2.2) unstable; urgency=medium

  * Non-maintainer upload.

  [ Niels Thykier ]
  * Cherry-pick patch from gnulib upstream to make gzip build
    with glibc/2.28.  (Closes: #915150)
  * Declare that gzip does not need (fake)root for building the
    debs.
  * Add patch to remove incorrect -Wabi as -Wabi should always
    take a parameter (e.g. -Wabi=11) and it fails with -Werror=abi.
  * Add a patch to remove -Werror(=...) as it trips on some gnulib
    code.
  * Include autopkgtest based on the version by Steve Langasek for
    Ubuntu.
  * Remove fallback code to use dh_clean -k.
  * Remove usage of deprecated -s parameter for debhelper commands
    (replacing them with "-a").
  * Add a Homepage field.  Thanks to Jakub Wilk for the suggestion.
    (Closes: #888619)
  * Remove empty lintian override directory.

  [ Andreas Henriksson ]
  * Set GREP=grep during configure, otherwise zgrep embeds the full
    path. (Closes: #914907)

debian/changelog
debian/control
debian/dirs
debian/patches/disable-Werror.patch [new file with mode: 0644]
debian/patches/disable-broken-Wabi.patch [new file with mode: 0644]
debian/patches/gnulib-4af4a4a71827c0bc5.patch [new file with mode: 0644]
debian/patches/series
debian/rules
debian/tests/control [new file with mode: 0644]
debian/tests/simple-gzip [new file with mode: 0755]

index 6b91304467358962f11389933c163b627aca85d4..6cb29ef4b8cb9a4a9c44b2ecc5ad1f0ad6002d1d 100644 (file)
@@ -1,3 +1,31 @@
+gzip (1.9-2.2) unstable; urgency=medium
+
+  * Non-maintainer upload.
+
+  [ Niels Thykier ]
+  * Cherry-pick patch from gnulib upstream to make gzip build
+    with glibc/2.28.  (Closes: #915150)
+  * Declare that gzip does not need (fake)root for building the
+    debs.
+  * Add patch to remove incorrect -Wabi as -Wabi should always
+    take a parameter (e.g. -Wabi=11) and it fails with -Werror=abi.
+  * Add a patch to remove -Werror(=...) as it trips on some gnulib
+    code.
+  * Include autopkgtest based on the version by Steve Langasek for
+    Ubuntu.
+  * Remove fallback code to use dh_clean -k.
+  * Remove usage of deprecated -s parameter for debhelper commands
+    (replacing them with "-a").
+  * Add a Homepage field.  Thanks to Jakub Wilk for the suggestion.
+    (Closes: #888619)
+  * Remove empty lintian override directory.
+
+  [ Andreas Henriksson ]
+  * Set GREP=grep during configure, otherwise zgrep embeds the full
+    path. (Closes: #914907)
+
+ -- Niels Thykier <niels@thykier.net>  Fri, 28 Dec 2018 14:34:28 +0000
+
 gzip (1.9-2.1) unstable; urgency=medium
 
   * Non-maintainer upload.
index b1637275f2f3e8841829a5b67792016156f07458..d5227967cb2325c04b31716454b2ae669e43c3f4 100644 (file)
@@ -5,9 +5,11 @@ Maintainer: Bdale Garbee <bdale@gag.com>
 Uploaders: Carl Worth <cworth@cworth.org>
 Build-Depends: debhelper (>= 11), texinfo, autoconf, automake, less
 Build-Depends-Indep: mingw-w64
+Rules-Requires-Root: no
 Standards-Version: 4.1.5
 Vcs-Git: git://git.gag.com/debian/gzip
 Vcs-Browser: https://git.gag.com/?p=debian/gzip
+Homepage: https://www.gnu.org/software/gzip/
 
 Package: gzip
 Architecture: any
index b90abddd6047185d7539c2b735129f5797661331..e1cfbedf98f7ac3914533b9b4695c9c91df96ee6 100644 (file)
@@ -1,4 +1,3 @@
 bin
 usr/share/info
-usr/share/lintian/overrides
 usr/share/man/man1
diff --git a/debian/patches/disable-Werror.patch b/debian/patches/disable-Werror.patch
new file mode 100644 (file)
index 0000000..276d55e
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 1f05a7e..7b34c4b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -93,7 +93,7 @@ AC_DEFUN([gl_GCC_VERSION_IFELSE],
+ )
+ if test "$gl_gcc_warnings" = yes; then
+-  gl_WARN_ADD([-Werror], [WERROR_CFLAGS])
++  gl_WARN_ADD([], [WERROR_CFLAGS])
+   AC_SUBST([WERROR_CFLAGS])
+   nw=
diff --git a/debian/patches/disable-broken-Wabi.patch b/debian/patches/disable-broken-Wabi.patch
new file mode 100644 (file)
index 0000000..6f8b395
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/m4/manywarnings.m4 b/m4/manywarnings.m4
+index dda3d46..71c2e1c 100644
+--- a/m4/manywarnings.m4
++++ b/m4/manywarnings.m4
+@@ -114,7 +114,6 @@ m4_defun([gl_MANYWARN_ALL_GCC(C)],
+   gl_manywarn_set=
+   for gl_manywarn_item in -fno-common \
+     -W \
+-    -Wabi \
+     -Waddress \
+     -Waggressive-loop-optimizations \
+     -Wall \
diff --git a/debian/patches/gnulib-4af4a4a71827c0bc5.patch b/debian/patches/gnulib-4af4a4a71827c0bc5.patch
new file mode 100644 (file)
index 0000000..4ab2fe3
--- /dev/null
@@ -0,0 +1,157 @@
+From 4af4a4a71827c0bc5e0ec67af23edef4f15cee8e Mon Sep 17 00:00:00 2001
+From: Paul Eggert <eggert@cs.ucla.edu>
+Date: Mon, 5 Mar 2018 10:56:29 -0800
+Subject: fflush: adjust to glibc 2.28 libio.h removal
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Problem reported by Daniel P. BerrangĂ© in:
+https://lists.gnu.org/r/bug-gnulib/2018-03/msg00000.html
+* lib/fbufmode.c (fbufmode):
+* lib/fflush.c (clear_ungetc_buffer_preserving_position)
+(disable_seek_optimization, rpl_fflush):
+* lib/fpending.c (__fpending):
+* lib/fpurge.c (fpurge):
+* lib/freadable.c (freadable):
+* lib/freadahead.c (freadahead):
+* lib/freading.c (freading):
+* lib/freadptr.c (freadptr):
+* lib/freadseek.c (freadptrinc):
+* lib/fseeko.c (fseeko):
+* lib/fseterr.c (fseterr):
+* lib/fwritable.c (fwritable):
+* lib/fwriting.c (fwriting):
+Check _IO_EOF_SEEN instead of _IO_ftrylockfile.
+* lib/stdio-impl.h (_IO_IN_BACKUP) [_IO_EOF_SEEN]:
+Define if not already defined.
+---
+ ChangeLog        | 23 +++++++++++++++++++++++
+ lib/fbufmode.c   |  2 +-
+ lib/fflush.c     |  6 +++---
+ lib/fpending.c   |  2 +-
+ lib/fpurge.c     |  2 +-
+ lib/freadable.c  |  2 +-
+ lib/freadahead.c |  2 +-
+ lib/freading.c   |  2 +-
+ lib/freadptr.c   |  2 +-
+ lib/freadseek.c  |  2 +-
+ lib/fseeko.c     |  4 ++--
+ lib/fseterr.c    |  2 +-
+ lib/fwritable.c  |  2 +-
+ lib/fwriting.c   |  2 +-
+ lib/stdio-impl.h |  6 ++++++
+ 15 files changed, 45 insertions(+), 16 deletions(-)
+
+diff --git a/lib/fflush.c b/lib/fflush.c
+index 983ade0..a6edfa1 100644
+--- a/lib/fflush.c
++++ b/lib/fflush.c
+@@ -33,7 +33,7 @@
+ #undef fflush
+-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
++#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+ /* Clear the stream's ungetc buffer, preserving the value of ftello (fp).  */
+ static void
+@@ -72,7 +72,7 @@ clear_ungetc_buffer (FILE *fp)
+ #endif
+-#if ! (defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
++#if ! (defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
+ # if (defined __sferror || defined __DragonFly__ || defined __ANDROID__) && defined __SNPT
+ /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
+@@ -148,7 +148,7 @@ rpl_fflush (FILE *stream)
+   if (stream == NULL || ! freading (stream))
+     return fflush (stream);
+-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
++#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+   clear_ungetc_buffer_preserving_position (stream);
+diff --git a/lib/fpurge.c b/lib/fpurge.c
+index b1d417c..3aedcc3 100644
+--- a/lib/fpurge.c
++++ b/lib/fpurge.c
+@@ -62,7 +62,7 @@ fpurge (FILE *fp)
+   /* Most systems provide FILE as a struct and the necessary bitmask in
+      <stdio.h>, because they need it for implementing getc() and putc() as
+      fast macros.  */
+-# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
++# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+   fp->_IO_read_end = fp->_IO_read_ptr;
+   fp->_IO_write_ptr = fp->_IO_write_base;
+   /* Avoid memory leak when there is an active ungetc buffer.  */
+diff --git a/lib/freading.c b/lib/freading.c
+index 73c28ac..c24d0c8 100644
+--- a/lib/freading.c
++++ b/lib/freading.c
+@@ -31,7 +31,7 @@ freading (FILE *fp)
+   /* Most systems provide FILE as a struct and the necessary bitmask in
+      <stdio.h>, because they need it for implementing getc() and putc() as
+      fast macros.  */
+-# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
++# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+   return ((fp->_flags & _IO_NO_WRITES) != 0
+           || ((fp->_flags & (_IO_NO_READS | _IO_CURRENTLY_PUTTING)) == 0
+               && fp->_IO_read_base != NULL));
+diff --git a/lib/fseeko.c b/lib/fseeko.c
+index 0101ab5..193f4e8 100644
+--- a/lib/fseeko.c
++++ b/lib/fseeko.c
+@@ -47,7 +47,7 @@ fseeko (FILE *fp, off_t offset, int whence)
+ #endif
+   /* These tests are based on fpurge.c.  */
+-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
++#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+   if (fp->_IO_read_end == fp->_IO_read_ptr
+       && fp->_IO_write_ptr == fp->_IO_write_base
+       && fp->_IO_save_base == NULL)
+@@ -123,7 +123,7 @@ fseeko (FILE *fp, off_t offset, int whence)
+           return -1;
+         }
+-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
++#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+       fp->_flags &= ~_IO_EOF_SEEN;
+       fp->_offset = pos;
+ #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
+diff --git a/lib/fseterr.c b/lib/fseterr.c
+index 82649c3..adb6372 100644
+--- a/lib/fseterr.c
++++ b/lib/fseterr.c
+@@ -29,7 +29,7 @@ fseterr (FILE *fp)
+   /* Most systems provide FILE as a struct and the necessary bitmask in
+      <stdio.h>, because they need it for implementing getc() and putc() as
+      fast macros.  */
+-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
++#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+   fp->_flags |= _IO_ERR_SEEN;
+ #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
+   /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
+diff --git a/lib/stdio-impl.h b/lib/stdio-impl.h
+index 78d896e..05c5752 100644
+--- a/lib/stdio-impl.h
++++ b/lib/stdio-impl.h
+@@ -18,6 +18,12 @@
+    the same implementation of stdio extension API, except that some fields
+    have different naming conventions, or their access requires some casts.  */
++/* Glibc 2.28 made _IO_IN_BACKUP private.  For now, work around this
++   problem by defining it ourselves.  FIXME: Do not rely on glibc
++   internals.  */
++#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN
++# define _IO_IN_BACKUP 0x100
++#endif
+ /* BSD stdio derived implementations.  */
+-- 
+cgit v1.0-41-gc330
+
index 69f81e332c897e24844a3c842408abfeb2738362..1df799305e06cc76077ea6b853f021cbccc91e09 100644 (file)
@@ -3,3 +3,6 @@ gzip_reproducible_build.diff
 zgrep-syntax-error.diff
 0001-gzip-port-better-to-mingw.patch
 0001-gzip-port-better-to-mingw-again.patch
+gnulib-4af4a4a71827c0bc5.patch
+disable-broken-Wabi.patch
+disable-Werror.patch
index 6936ecb71696c88546e352000fd5cb34ef8b7c45..26fb1a62006032ebcc2a895ba13810670e04e077 100755 (executable)
@@ -78,7 +78,7 @@ configure-stamp: reconf-stamp
        mkdir -p builddir
        cd builddir && env \
            $(foreach i,CC CFLAGS CPPFLAGS LDFLAGS,$(call shellexport,$i)) \
-           CONFIG_SHELL=/bin/sh ../configure ${CONFIGURE_ARGS}
+           CONFIG_SHELL=/bin/sh GREP=grep ../configure ${CONFIGURE_ARGS}
        :>$@
 
 configure-indep: configure-indep-stamp
@@ -119,7 +119,7 @@ binary: binary-arch binary-indep
 binary-indep: build-indep-stamp
        dh_testdir
        dh_testroot
-       if test -x "$$(which dh_prep)"; then dh_prep; else dh_clean -k; fi
+       dh_prep
        dh_installdirs
        i686-w64-mingw32-strip builddir-indep/gzip.exe
        install -m 0755 builddir-indep/gzip.exe \
@@ -137,32 +137,32 @@ binary-indep: build-indep-stamp
 binary-arch: build-stamp
        dh_testdir
        dh_testroot
-       if test -x "$$(which dh_prep)"; then dh_prep; else dh_clean -k; fi
+       dh_prep
        dh_installdirs
        ${MAKE} -C builddir install \
            prefix=${_topdir}/debian/gzip/usr \
            bindir=${_topdir}/debian/gzip/bin
-       dh_testdir -s
-       dh_testroot -s
-       dh_installdocs -s README* TODO
+       dh_testdir -a
+       dh_testroot -a
+       dh_installdocs -a README* TODO
        dh_installman *.1
-       dh_installinfo -s doc/gzip.info
-       dh_installchangelogs -s ChangeLog
-       dh_link -s
-       dh_lintian -s
-       dh_strip -s
-       dh_compress -s
+       dh_installinfo -a doc/gzip.info
+       dh_installchangelogs -a ChangeLog
+       dh_link -a
+       dh_lintian -a
+       dh_strip -a
+       dh_compress -a
        ln -s gunzip.1.gz debian/gzip/usr/share/man/man1/uncompress.1.gz
        ln -s zgrep.1.gz debian/gzip/usr/share/man/man1/zegrep.1.gz
        ln -s zgrep.1.gz debian/gzip/usr/share/man/man1/zfgrep.1.gz
        rm -f ${_topdir}/debian/gzip/usr/share/info/dir.gz
-       dh_fixperms -s
-       dh_makeshlibs -s
-       dh_installdeb -s
-       dh_shlibdeps -s
-       dh_gencontrol -s
-       dh_md5sums -s
-       dh_builddeb -s
+       dh_fixperms -a
+       dh_makeshlibs -a
+       dh_installdeb -a
+       dh_shlibdeps -a
+       dh_gencontrol -a
+       dh_md5sums -a
+       dh_builddeb -a
 
 .PHONY: binary binary-arch binary-indep build build-arch build-indep clean
 .PHONY: configure configure-indep
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644 (file)
index 0000000..ad73a0d
--- /dev/null
@@ -0,0 +1,2 @@
+Tests: simple-gzip
+Depends: gzip
diff --git a/debian/tests/simple-gzip b/debian/tests/simple-gzip
new file mode 100755 (executable)
index 0000000..2f09030
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+set -e
+
+echo "Blablablablablablablablablablablablablabla" > bla.file
+cp bla.file bla.file.orig
+gzip bla.file
+gzip -l bla.file.gz
+gunzip bla.file.gz
+cmp bla.file bla.file.orig
+rm bla.file bla.file.orig