Revert "patch to improve behavior of zdiff when file is compressed without extension" debian/1.4-6
authorBdale Garbee <bdale@gag.com>
Fri, 13 Apr 2012 05:20:17 +0000 (23:20 -0600)
committerBdale Garbee <bdale@gag.com>
Fri, 13 Apr 2012 05:20:17 +0000 (23:20 -0600)
This reverts commit b2747d0988265018e8b4db1ba44214b0e506d09a.

Unfortunately, this patch breaks 'make check' ...

debian/changelog
debian/patches/series
debian/patches/zdiff-file.diff [deleted file]
zdiff.in

index 0e272629d65ec2d11ba7a1a82caed10dad7f2723..7d07c2ca9dcc60b19ddd6d38d467dc29978beea5 100644 (file)
@@ -7,8 +7,6 @@ gzip (1.4-6) unstable; urgency=low
     closes: #637626
   * patch to improve zdiff doc from Stéphane Aulery, closes: #269612
   * patches to fix RFC URLs from Stéphane Aulery, closes: #636182
-  * patch from Stéphane Aulery to improve zdiff behavior when file is
-    compressed without explicit extension, closes: #343575, #630111
 
  -- Bdale Garbee <bdale@gag.com>  Thu, 12 Apr 2012 23:11:46 -0600
 
index f85a0929be74aefc6459663a39738b3840c45fcf..c6482a46ff612564e0370262645832f9d2a8077a 100644 (file)
@@ -7,4 +7,3 @@ zgrep-dash-h.diff
 gzip-man-pack.diff
 zdiff-man.diff
 rfc-urls.diff
-zdiff-file.diff
diff --git a/debian/patches/zdiff-file.diff b/debian/patches/zdiff-file.diff
deleted file mode 100644 (file)
index ea7bc6d..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/zdiff.in b/zdiff.in
-index 9d3b4ae..506a888 100644
---- a/zdiff.in
-+++ b/zdiff.in
-@@ -76,9 +76,15 @@ gzip_status=0
- exec 3>&1
- if test $# -eq 1; then
--  case $1 in
--  *[-.]gz* | *[-.][zZ] | *.t[ga]z)
-+  type_file=$(file -b --mime-type "$1")
-+
-+  case $type_file in
-+  application/x-gzip | application/x-compress)
-     FILE=`expr "X$1" : 'X\(.*\)[-.][zZtga]*$'`
-+    if test "$FILE" == ""; then
-+        FILE="$1"
-+    fi;
-+    
-     gzip_status=$(
-       exec 4>&1
-       (gzip -cd -- "$1" 4>&-; echo $? >&4) 3>&- | eval "$cmp" - '"$FILE"' >&3
-@@ -88,10 +94,13 @@ if test $# -eq 1; then
-     exit 2;;
-   esac
- elif test $# -eq 2; then
--      case "$1" in
--      *[-.]gz* | *[-.][zZ] | *.t[ga]z | -)
--                case "$2" in
--              *[-.]gz* | *[-.][zZ] | *.t[ga]z | -)
-+      type_file1=$(file -b --mime-type "$1")
-+      type_file2=$(file -b --mime-type "$2")
-+      
-+      case "$type_file1" in
-+      application/x-gzip | application/x-compress)
-+                case "$type_file2" in
-+              application/x-gzip | application/x-compress)
-                   if test "$1$2" = --; then
-                       gzip_status=$(
-                         exec 4>&1
-@@ -118,6 +127,9 @@ elif test $# -eq 2; then
-                       (exit $cmp_status)
-                   else
-                       F=`expr "/$2" : '.*/\(.*\)[-.][zZtga]*$'` || F=$prog
-+                      if test "$F" == ""; then
-+                          F="$2"
-+                      fi;
-                       tmp=
-                       trap '
-                         test -n "$tmp" && rm -f "$tmp"
-@@ -147,8 +159,8 @@ elif test $# -eq 2; then
-                       eval "$cmp" - '"$2"' >&3
-                   );;
-                 esac;;
--        *)      case "$2" in
--              *[-.]gz* | *[-.][zZ] | *.t[ga]z | -)
-+        *)      case "$type_file2" in
-+              application/x-gzip | application/x-compress)
-                       gzip_status=$(
-                         exec 4>&1
-                         (gzip -cdfq -- "$2" 4>&-; echo $? >&4) 3>&- |
index 506a888ef2d78390d9d6e8eec497b63c37d673a5..9d3b4aed0a1bd842b84a1b7e71ba2fa987d367af 100644 (file)
--- a/zdiff.in
+++ b/zdiff.in
@@ -76,15 +76,9 @@ gzip_status=0
 exec 3>&1
 
 if test $# -eq 1; then
-  type_file=$(file -b --mime-type "$1")
-
-  case $type_file in
-  application/x-gzip | application/x-compress)
+  case $1 in
+  *[-.]gz* | *[-.][zZ] | *.t[ga]z)
     FILE=`expr "X$1" : 'X\(.*\)[-.][zZtga]*$'`
-    if test "$FILE" == ""; then
-        FILE="$1"
-    fi;
-    
     gzip_status=$(
       exec 4>&1
       (gzip -cd -- "$1" 4>&-; echo $? >&4) 3>&- | eval "$cmp" - '"$FILE"' >&3
@@ -94,13 +88,10 @@ if test $# -eq 1; then
     exit 2;;
   esac
 elif test $# -eq 2; then
-       type_file1=$(file -b --mime-type "$1")
-       type_file2=$(file -b --mime-type "$2")
-       
-       case "$type_file1" in
-       application/x-gzip | application/x-compress)
-                case "$type_file2" in
-               application/x-gzip | application/x-compress)
+       case "$1" in
+       *[-.]gz* | *[-.][zZ] | *.t[ga]z | -)
+                case "$2" in
+               *[-.]gz* | *[-.][zZ] | *.t[ga]z | -)
                    if test "$1$2" = --; then
                        gzip_status=$(
                          exec 4>&1
@@ -127,9 +118,6 @@ elif test $# -eq 2; then
                        (exit $cmp_status)
                    else
                        F=`expr "/$2" : '.*/\(.*\)[-.][zZtga]*$'` || F=$prog
-                       if test "$F" == ""; then
-                           F="$2"
-                       fi;
                        tmp=
                        trap '
                          test -n "$tmp" && rm -f "$tmp"
@@ -159,8 +147,8 @@ elif test $# -eq 2; then
                        eval "$cmp" - '"$2"' >&3
                    );;
                 esac;;
-        *)      case "$type_file2" in
-               application/x-gzip | application/x-compress)
+        *)      case "$2" in
+               *[-.]gz* | *[-.][zZ] | *.t[ga]z | -)
                        gzip_status=$(
                          exec 4>&1
                          (gzip -cdfq -- "$2" 4>&-; echo $? >&4) 3>&- |