tests: exercise the grep -e portability fix
authorPaul Eggert <eggert@cs.ucla.edu>
Wed, 24 Oct 2012 22:37:01 +0000 (15:37 -0700)
committerPaul Eggert <eggert@cs.ucla.edu>
Wed, 24 Oct 2012 22:37:25 +0000 (15:37 -0700)
Remove workaround for Solaris, since the bug should be fixed now.
Suggested by Petr Sumbera in
<http://lists.gnu.org/archive/html/bug-gzip/2012-10/msg00005.html>.
* tests/zgrep-context, tests/zgrep-f: All uses removed.
* tests/init.cfg (require_POSIX_grep_): Remove.

tests/init.cfg
tests/zgrep-context
tests/zgrep-f

index 5adfc9b357a134dcadd90de07838a535f84739fa..901209ceae96dd53ef2d110784fdba39c98254b4 100644 (file)
@@ -3,18 +3,3 @@
 # This goes hand in hand with the "exec 9>&2;" in Makefile.am's
 # TESTS_ENVIRONMENT definition.
 stderr_fileno_=9
-
-require_POSIX_grep_()
-{
-  # Ensure that grep's -f and -E options works.
-  # On Solaris 5.11, "grep -f" prints this:
-  #   grep: illegal option -- f
-  #   Usage: grep -hblcnsviw pattern file . . .
-  # Similar for grep -E.
-
-  : | grep -f /dev/null
-  test $? = 1 || skip_ 'your grep lacks support for -f -'
-
-  grep -E foo /dev/null
-  test $? = 1 || skip_ 'your grep lacks support for -E'
-}
index 1a15fa88ee43cebf260437501ad25424aa9192d9..fc40aa02d8b384cc16a1d578f772d0f798ddfe0e 100755 (executable)
@@ -19,8 +19,6 @@
 
 . "${srcdir=.}/init.sh"; path_prepend_ ..
 
-require_POSIX_grep_
-
 # A limited replacement for seq: handle 1 or 2 args; increment must be 1
 seq()
 {
index c494706e2a8d9b1f3f083e20f0aa5b0023336024..4e9ccd0a69b4fa090fc2d533931b46f36e99bf3b 100755 (executable)
@@ -20,8 +20,6 @@
 
 . "${srcdir=.}/init.sh"; path_prepend_ ..
 
-require_POSIX_grep_
-
 echo needle > n || framework_failure_
 echo needle > haystack || framework_failure_
 gzip haystack || framework_failure_