fix some lintian whining
authorBdale Garbee <bdale@gag.com>
Sun, 29 Jul 2018 07:05:42 +0000 (15:05 +0800)
committerBdale Garbee <bdale@gag.com>
Sun, 29 Jul 2018 07:05:42 +0000 (15:05 +0800)
debian/changelog
debian/compat
debian/control
debian/rules

index fe6dbbccc48d80f01802345ffcc736699755b727..852615f2a1dae0bdd22cea7b746e5d8762c28261 100644 (file)
@@ -6,6 +6,8 @@ gzip (1.9-1) UNRELEASED; urgency=medium
     closes: #854878
   * update to policy 4.1.5, including use of https in vcs entries
   * patch gzip.c to work around mingw compiliation failure
+  * use optional priority for gzip-win32 now that extra is deprecated
+  * use architecture.mk instead of setting ARCH vars by hand in rules
 
  -- Bdale Garbee <bdale@gag.com>  Sun, 29 Jul 2018 14:44:12 +0800
 
index 7ed6ff82de6bcc2a78243fc9c54d3ef5ac14da69..b4de3947675361a7770d29b8982c407b0ec6b2a0 100644 (file)
@@ -1 +1 @@
-5
+11
index 24fdb86d379d2533956bb1d4eefc2dcadd585957..ce5f1c7993444df2ff1008ecfbffd2356ee5d9fe 100644 (file)
@@ -23,7 +23,7 @@ Description: GNU compression utilities
 
 Package: gzip-win32
 Architecture: all
-Priority: extra
+Priority: optional
 Suggests: wine
 Description: GNU compression utility (win32 build)
  This is a win32 version of gzip, meant to be used by the win32-loader
index 2354cc248c9ad0214265512d49789dc7453070d6..7ef38f52b89fb3b6d53e81ee642820c8e363f663 100755 (executable)
@@ -10,9 +10,7 @@ export DH_VERBOSE=1
 shellescape='$(subst ','\'',$(1))'
 shellexport=$(1)=$(call shellescape,${$(1)})
 
-DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
-DEB_HOST_ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH)
-DEB_HOST_GNU_TYPE=$(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+include /usr/share/dpkg/architecture.mk
 
 # Automatic ${CC} selection for cross-compiles