explicitly link -lssp when building with mingw
authorBdale Garbee <bdale@gag.com>
Tue, 25 Feb 2020 23:10:42 +0000 (16:10 -0700)
committerBdale Garbee <bdale@gag.com>
Tue, 25 Feb 2020 23:10:42 +0000 (16:10 -0700)
debian/rules

index 73f21873264793b418397b513ade2cde13942b3d..3a68734a292b3146d1d3d699a171c8e2cfb13f7b 100755 (executable)
@@ -85,7 +85,7 @@ configure-indep: configure-indep-stamp
 configure-indep-stamp: reconf-stamp
        dh_testdir
        mkdir -p builddir-indep
-       cd builddir-indep && ../configure --host=i686-w64-mingw32
+       cd builddir-indep && ../configure --host=i686-w64-mingw32 LIBS="-Wl,--as-needed -lssp"
        :>$@
 
 build: build-stamp build-indep-stamp