fix for #644785
[debian/gzip] / debian / rules
index 3361d69b68bfc5ee15054f59731d10bd503449e5..3f9891e0ab9d746975a959d5a51ad69bb4731e4a 100755 (executable)
@@ -11,8 +11,7 @@ ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
 CONFARGS = --host=$(DEB_HOST_GNU_TYPE)
 endif
 
-buildarch := $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-ifeq ($(buildarch),amd64)
+ifeq ($(shell dpkg-architecture -qDEB_HOST_ARCH),amd64)
 CFLAGS=-g -O2 -Wall -DUNALIGNED_OK
 else
 CFLAGS=-g -O2 -Wall