Tweaks for svn-buildpackage
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 21 May 2009 00:28:53 +0000 (00:28 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 21 May 2009 00:28:53 +0000 (00:28 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@11080 221aa14e-8319-0410-a670-987f0aec2ac5

debian/build-bin.sh
debian/changelog
debian/control
debian/rules
usrp2/firmware/configure.gnu

index 2ffea9e456224c83a9017a2347a3c4e6c6f216da..3ed488023419758804891638752e7a21c409e54d 100755 (executable)
@@ -8,5 +8,3 @@ svn-buildpackage \
     --svn-reuse \
     -nc \
     -rfakeroot
-
-
index ccc89b9ce4c91c203603c13e4ca149f71087b492..2daa23763ef4500e8c2480df5e2ea9d870376945 100644 (file)
@@ -3,7 +3,7 @@ gnuradio (3.2.svn) unstable; urgency=low
   * post release 3.2 trunk repository packages
   * see http://gnuradio.org/trac/wiki for stable branch
 
- -- Johnathan Corgan <jcorgan@corganenterprises.com>  Mon,  4 May 2009 18:00:00 -0800
+ -- Johnathan Corgan <jcorgan@corganenterprises.com>  Wed,  20 May 2009 18:00:00 -0800
 
 gnuradio (3.0.svn) unstable; urgency=low
 
index 6b06462888cbf94591b18d1a96d7e30ad86066a1..695b61045fce1c0e83e386190ce7f88eb42e0adf 100644 (file)
@@ -7,7 +7,7 @@ Section: comm
 Priority: optional
 Maintainer: Johnathan Corgan <jcorgan@corganenterprises.com>
 Build-Conflicts: automake1.8, automake1.9
-Build-Depends: debhelper (>= 5.0.37.2), build-essential, automake, libtool, pkg-config, python-dev, swig, fftw3-dev | libfftw3-dev, libcppunit-dev, libboost1.37-dev, libgsl0-dev, guile-1.8, libasound2-dev, python-wxgtk2.8, python-numpy, doxygen, xmlto, sdcc-nf, libusb-dev, libjack-dev, portaudio19-dev, libsdl1.2-dev, python-cheetah, python-lxml, python-gtk2
+Build-Depends: debhelper (>= 5.0.37.2), build-essential, automake, libtool, pkg-config, python-dev, swig, fftw3-dev | libfftw3-dev, libcppunit-dev, libboost1.37-dev, libgsl0-dev, guile-1.8, libasound2-dev, python-wxgtk2.8, python-numpy, doxygen, xmlto, sdcc-nf, libusb-dev, libjack-dev, portaudio19-dev, libsdl1.2-dev, python-cheetah, python-lxml, python-gtk2, libqt4-dev, libqwt5-qt4-dev, libqwtplot3d-qt4-dev
 Standards-Version: 3.7.2
 XS-Python-Version: = 2.6
 
index 4a477732c37168562ae95d983f916eafc8140fe0..fe17823551bba66e75983f8a5c07b22f665c8e27 100755 (executable)
@@ -51,7 +51,7 @@ configure-stamp:
 build: build-stamp
 build-stamp: configure-stamp
 
-       $(MAKE) -j
+       $(MAKE)
        $(MAKE) check
        touch $@
 
@@ -107,8 +107,7 @@ binary-common:
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
-       mkdir -p ../debfiles
-       dh_builddeb --destdir=../debfiles
+       dh_builddeb
 
 # Build architecture independant packages using the common target.
 binary-indep: build install
index 8a047199556f826f9a03c83799168f538aa6436d..60d6d2a7ecb2118ac084b6d25f45f54dfa9a8346 100755 (executable)
@@ -21,6 +21,7 @@ do
       (RANLIB=*)   ;;
       (STRIP=*)    ;;
       (F77=*)      ;;
+      (FFLAGS=*)   ;;
       (CFLAGS=*)   ;;
       (CXXFLAGS=*) ;;
       (CPPFLAGS=*) ;;