revert extraction of buffer_state
authoreb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 23 Jan 2009 02:12:04 +0000 (02:12 +0000)
committereb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 23 Jan 2009 02:12:04 +0000 (02:12 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@10294 221aa14e-8319-0410-a670-987f0aec2ac5

usrp2/firmware/lib/Makefile.am
usrp2/firmware/lib/bsm12.c
usrp2/firmware/lib/buffer_state.c [deleted file]
usrp2/firmware/lib/buffer_state.h [deleted file]
usrp2/firmware/lib/dbsm.c

index 027b6ac9bed0da64a29e524d26eea9eb9d35e0b3..4c26330808e5724cb1c47ab220f732160a241634 100644 (file)
@@ -27,7 +27,6 @@ libu2fw_a_SOURCES = \
        ad9777.c \
        bsm12.c \
        buffer_pool.c \
-       buffer_state.c \
        clocks.c \
        db_basic.c \
        db_init.c \
@@ -66,7 +65,6 @@ noinst_HEADERS = \
        bool.h \
        bsm12.h \
        buffer_pool.h \
-       buffer_state.h \
        clocks.h \
        db.h \
        db_base.h \
index 25c5a3fdae33e49111666428f61aec055343f537..845046d6565540283530b2c44f9ba0aec1824edd 100644 (file)
 #include "buffer_pool.h"
 #include "bool.h"
 #include "nonstdio.h"
-#include "buffer_state.h"
 #include <stdlib.h>
 
+typedef enum {
+  BS_EMPTY,
+  BS_FILLING,
+  BS_FULL,
+  BS_EMPTYING,
+} buffer_state_t;
+
+static buffer_state_t buffer_state[NBUFFERS];
+static unsigned char  buffer_dst[NBUFFERS];    // 0 or 1
 static uint32_t last_send_ctrl[NBUFFERS];
 
 void
diff --git a/usrp2/firmware/lib/buffer_state.c b/usrp2/firmware/lib/buffer_state.c
deleted file mode 100644 (file)
index cea5022..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-/* -*- c++ -*- */
-/*
- * Copyright 2009 Free Software Foundation, Inc.
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program.  If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include "buffer_state.h"
-
-buffer_state_t buffer_state[NBUFFERS];
diff --git a/usrp2/firmware/lib/buffer_state.h b/usrp2/firmware/lib/buffer_state.h
deleted file mode 100644 (file)
index f855dc4..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-/* -*- c++ -*- */
-/*
- * Copyright 2009 Free Software Foundation, Inc.
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program.  If not, see <http://www.gnu.org/licenses/>.
- */
-
-#ifndef INCLUDED_BUFFER_STATE_H
-#define INCLUDED_BUFFER_STATE_H
-
-#include "memory_map.h"
-
-typedef enum {
-  BS_EMPTY,
-  BS_FILLING,
-  BS_FULL,
-  BS_EMPTYING,
-} buffer_state_t;
-
-extern buffer_state_t buffer_state[NBUFFERS];
-
-#endif /* INCLUDED_BUFFER_STATE_H */
index cfe911538fe77dd6c0596efdffbfef6bad127f4c..8f774d9162bfe090b6ceaf380b76d35fb2c9268b 100644 (file)
 #include "buffer_pool.h"
 #include "bool.h"
 #include "nonstdio.h"
-#include "buffer_state.h"
 #include <stdlib.h>
 
+typedef enum {
+  BS_EMPTY,
+  BS_FILLING,
+  BS_FULL,
+  BS_EMPTYING,
+} buffer_state_t;
+
+static buffer_state_t buffer_state[NBUFFERS];
+
 bool
 dbsm_nop_inspector(dbsm_t *sm, int buf_this)
 {