Imported Debian patch 3.6-3.1 debian/3.6-3.1
authorSteve Langasek <vorlon@debian.org>
Mon, 12 Mar 2007 10:44:09 +0000 (03:44 -0700)
committerBdale Garbee <bdale@gag.com>
Tue, 20 May 2008 05:09:36 +0000 (23:09 -0600)
debian/changelog
debian/elilo.config
debian/postinst

index 31ace07c208bec1bc6ff536d0c8bea7bd296f9c5..45f052168245701e0bca533d0c9f7b55c0f36aae 100644 (file)
@@ -1,3 +1,16 @@
+elilo (3.6-3.1) unstable; urgency=high
+
+  * Non-maintainer upload.
+  * High-urgency upload for RC bugfix.
+  * The check for new installs is broken, because apt-install elilo is
+    apparently not guaranteed to complete before the fstab is configured;
+    instead, check for the existence of /etc/elilo.conf to determine 
+    whether to run elilo on install.  Closes: #414419.
+  * Also fix a missing $ in the debconf config script that caused a syntax
+    error.
+
+ -- Steve Langasek <vorlon@debian.org>  Mon, 12 Mar 2007 03:44:09 -0700
+
 elilo (3.6-3) unstable; urgency=high
 
   * patch from Dann Frazier that adds an option to run /usr/sbin/elilo in 
index eb8c0a98ae004f572bdeac14248e6f865f9bbaf3..820a2a799692bc96c7216c33158ab7000553106e 100644 (file)
@@ -4,7 +4,7 @@ set -e
 
 . /usr/share/debconf/confmodule
 
-if [ "2" ] && dpkg --compare-versions $2 lt 3.2-1
+if [ "$2" ] && dpkg --compare-versions $2 lt 3.2-1
 then
   db_input high elilo/format || true
 else
index 465c7a99e9af8ac05bec45dc1621bd3c10636d7c..e1bde698f52c82f64cdc8d7a8005a5f59bd15ee8 100644 (file)
@@ -10,22 +10,21 @@ fi
 case "$1" in
     configure|reconfigure)
        # On new installs, do nothing - elilo-installer will handle it for d-i
-       if grep -q "^# UNCONFIGURED FSTAB FOR BASE SYSTEM" /etc/fstab ; then
-         exit 0
-       fi
-        if [ "$2" ] && dpkg --compare-versions $2 lt 3.2-1
-        then
-            db_get elilo/format || true;
-            if [ x"$RET" = x"true" ]; then
-                echo "Running elilo..."
-                /usr/sbin/elilo --format --efiboot
+       if [ -e /etc/elilo.conf ]; then
+            if [ "$2" ] && dpkg --compare-versions "$2" lt 3.2-1
+            then
+                db_get elilo/format || true;
+                if [ x"$RET" = x"true" ]; then
+                    echo "Running elilo..."
+                    /usr/sbin/elilo --format --efiboot
+                fi
+            else
+                db_get elilo/runme || true;
+                if [ x"$RET" = x"true" ]; then
+                    echo "Running elilo..."
+                    /usr/sbin/elilo
+                fi
             fi
-            exit 0
-        fi
-        db_get elilo/runme || true;
-        if [ x"$RET" = x"true" ]; then
-            echo "Running elilo..."
-            /usr/sbin/elilo
         fi
     ;;