Imported Debian patch 0.5.3-1.1 debian/0.5.3-1.1
authorSam Hocevar (Debian packages) <sam+deb@zoy.org>
Sun, 8 Oct 2006 12:21:38 +0000 (14:21 +0200)
committerBdale Garbee <bdale@gag.com>
Tue, 20 May 2008 05:06:23 +0000 (23:06 -0600)
debian/changelog
debian/control
src/include/gpt.h
src/lib/efi.c

index 1c8625121f0142b5a89202a38fcedba435bc541e..77c749f2f7c3544ccd5d5e61921162147b9bd0ee 100644 (file)
@@ -1,3 +1,17 @@
+efibootmgr (0.5.3-1.1) unstable; urgency=medium
+
+  * Non-maintainer upload.
+  * src/include/gpt.h:
+    + Fix GPT_HEADER_SIGNATURE declaration on 32bit architectures.
+  * src/lib/efi.c:
+    + Remove questionable "hack to allow include of ethtool.h".
+    + Include asm/types.h so that proper types are defined (Closes: #389923).
+  * debian/control:
+    + Set policy to 3.7.2.
+    + Uncapitalised short description.
+
+ -- Sam Hocevar (Debian packages) <sam+deb@zoy.org>  Sun,  8 Oct 2006 14:21:38 +0200
+
 efibootmgr (0.5.3-1) unstable; urgency=low
 
   * new upstream version, closes: #357884
index 516728fa3bfd964f313b93e304217df10480b98e..3d892d17d2762cd7583ac897dd28d022d0654f1a 100644 (file)
@@ -3,12 +3,12 @@ Section: admin
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
 Build-Depends: debhelper (>> 5), docbook-to-man, pciutils-dev
-Standards-Version: 3.6.2.2
+Standards-Version: 3.7.2
 
 Package: efibootmgr
 Architecture: amd64 i386 ia64
 Depends: ${shlibs:Depends}
-Description: Interact with the EFI Boot Manager 
+Description: interact with the EFI Boot Manager 
  This is a Linux user-space application to modify the Intel Extensible 
  Firmware Interface (EFI) Boot Manager configuration.  This application can 
  create and destroy boot entries, change the boot order, change the next 
index 89448851de229bc845f2b91c9385e663233d0fd3..1eefca37b874ed13eedf43c9407b401ec569228c 100644 (file)
@@ -35,7 +35,7 @@
 #define GPT_BLOCK_SIZE 512
 
 
-#define GPT_HEADER_SIGNATURE 0x5452415020494645
+#define GPT_HEADER_SIGNATURE ((uint64_t)(0x5452415020494645LL))
 #define GPT_HEADER_REVISION_V1_02 0x00010200
 #define GPT_HEADER_REVISION_V1_00 0x00010000
 #define GPT_HEADER_REVISION_V0_99 0x00009900
index 7dd2ab3aa5d8d2c1a48231cce526d9359aaf0759..a760eb185b70f209f7d1b733ad7f847053591144 100644 (file)
     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
  */
 
-#define _FILE_OFFSET_BITS 64
-
-typedef unsigned long long u64;       /* hack to allow include of ethtool.h */
-
 #include <ctype.h>
 #include <stdio.h>
 #include <stdlib.h>
@@ -39,6 +35,7 @@ typedef unsigned long long u64;       /* hack to allow include of ethtool.h */
 #include <linux/sockios.h>
 #include <net/if.h>
 #include <pci/pci.h>
+#include <asm/types.h>
 #include <linux/ethtool.h>
 #include "efi.h"
 #include "efichar.h"