Imported Debian patch 0.5.0-1 debian/0.5.0-1
authorBdale Garbee <bdale@gag.com>
Sat, 28 Aug 2004 17:51:02 +0000 (11:51 -0600)
committerBdale Garbee <bdale@gag.com>
Tue, 20 May 2008 05:06:19 +0000 (23:06 -0600)
Makefile
debian/changelog
doc/ChangeLog
src/lib/efi.c

index b7162d83b59122538d9abd93c2c29b362531cf6d..854277e8389cf1e083e63f0dc99f3c9a6fc07bc9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,10 +1,10 @@
   default: all
 
-  RELEASE_DATE := "09-Jun-2004"
+  RELEASE_DATE := "26-Aug-2004"
   RELEASE_MAJOR := 0
   RELEASE_MINOR := 5
   RELEASE_SUBLEVEL := 0
-  RELEASE_EXTRALEVEL := -test4
+  RELEASE_EXTRALEVEL :=
   RELEASE_NAME := efibootmgr
   RELEASE_STRING := $(RELEASE_NAME)-$(RELEASE_MAJOR).$(RELEASE_MINOR).$(RELEASE_SUBLEVEL)$(RELEASE_EXTRALEVEL)
 
index 5e57ff8f4b0506af298ff135f79e609edc04b7b0..a7025e5539bd4bdc022bde4613c0ce91c810128e 100644 (file)
@@ -1,3 +1,31 @@
+efibootmgr (0.5.0-1) unstable; urgency=low
+
+  * new upstream version.  No code changes from 0.5.0-test4, which I called
+    0.4.9 to avoid an epoch roll at this release... this upload just gets us
+    back in version sync with the official release from upstream.
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 28 Aug 2004 11:51:02 -0600
+
+efibootmgr (0.4.9-0.sarge.2) testing; urgency=high
+
+  * Base dependencies are frozen; this release reverts the portion of the
+    test4 changes that added a dependency on pciutils.  Thanks to Dann Frazier
+    for figuring this out and providing a suitable patch.  Closes: #268490
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 27 Aug 2004 23:12:38 -0600
+
+efibootmgr (0.4.9-0.sarge.1) testing; urgency=high
+
+  * build 0.4.9-1 in testing chroot for sarge
+  * new upstream version.  This is actually 0.5.0-test4, renumbered to avoid
+    nastiness when 0.5.0 is released.  Upstream says 0.5.0 will be this code
+    with a documentation change.  Closes: #258838, #235227
+  * add pciutils-dev to build dependencies since we need libpci now
+  * hack in a typedef to get a u64 definition for ethtool.h
+  * urgency high because previous version fails with current 2.6 kernels
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 18 Aug 2004 09:47:21 -0600
+
 efibootmgr (0.4.9-1) unstable; urgency=high
 
   * new upstream version.  This is actually 0.5.0-test4, renumbered to avoid
index 8ba7756904b7f3a1bb6a56bc08491442f402bacd..906bc6f3d7d8cad49539f386977609c6d94e9199 100644 (file)
@@ -1,3 +1,6 @@
+* Thu Aug 26 2004 Matt Domsch <Matt_Domsch@dell.com>
+- v0.5.0-test4 released as v0.5.0 with no code changes
+
 * Wed Jun 07 2004 Matt Domsch <Matt_Domsch@dell.com>
 - Fixed bug where read_boot_order() would wrongly return EFI_NOT_FOUND
   when it needed to create a new BootOrder variable.  Reported by Micah Parrish.
index dcc5e9195c6f91729e6ebb24fd9fd12cf938342e..26c144a347bd6fcab745051466d5d543b8502021 100644 (file)
@@ -20,6 +20,8 @@
 
 #define _FILE_OFFSET_BITS 64
 
+typedef unsigned long long u64;        /* hack to allow include of ethtool.h */
+
 #include <stdio.h>
 #include <stdlib.h>
 #include <string.h>
@@ -36,7 +38,6 @@
 #include <linux/sockios.h>
 #include <net/if.h>
 #include <pci/pci.h>
-typedef __u64 u64;
 #include <linux/ethtool.h>
 #include "efi.h"
 #include "efichar.h"