Imported Debian patch 0.5.3-3 debian/0.5.3-3
authorBdale Garbee <bdale@gag.com>
Wed, 12 Dec 2007 06:04:09 +0000 (23:04 -0700)
committerBdale Garbee <bdale@gag.com>
Tue, 20 May 2008 05:06:24 +0000 (23:06 -0600)
Makefile
debian/changelog
debian/control
debian/rules

index a52eef2606a0c171b4a547528ee33af51b876c8f..77e640dd0179c8e662450b27daa49c43a724c151 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,6 +11,8 @@
   CFLAGS += -DEFIBOOTMGR_VERSION=\"$(RELEASE_MAJOR).$(RELEASE_MINOR).$(RELEASE_SUBLEVEL)$(RELEASE_EXTRALEVEL)\" \
            -Wall -g -D_FILE_OFFSET_BITS=64
 
+  LDFLAGS += -lz
+
   MODULES := src
 
   BINDIR := /usr/sbin
index 3562b4314b8f8647c6571a1bb367e9f6d7112aa9..5bb9b543eaf85985073d9a001e6e4d48d1784b21 100644 (file)
@@ -1,3 +1,10 @@
+efibootmgr (0.5.3-3) unstable; urgency=low
+
+  * fix FTBFS, closes: #450448
+  * clean up a couple lintian warnings
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 11 Dec 2007 23:04:09 -0700
+
 efibootmgr (0.5.3-2) unstable; urgency=low
 
   * merge patch from Sam Hocevar (thanks!), closes: #389923
index 4f13b1797e5ad3f263715a7462d62a93d348253a..9f0d47169d86720f145fda743fbf7cf52e0653c5 100644 (file)
@@ -2,8 +2,8 @@ Source: efibootmgr
 Section: admin
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>> 5), docbook-to-man, pciutils-dev
-Standards-Version: 3.7.2
+Build-Depends: debhelper (>> 5), docbook-to-man, pciutils-dev, zlib1g-dev
+Standards-Version: 3.7.3
 
 Package: efibootmgr
 Architecture: amd64 i386 ia64
index 4d06695c23958191bbf40de3ce070013449f7a7e..cd1592155076c240bd1a3a764e09a56459ef2ae4 100755 (executable)
@@ -16,7 +16,7 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       -$(MAKE) clean
+       $(MAKE) clean
        dh_clean
 
 install: build