Merge commit 'upstream/2.12'
authorBdale Garbee <bdale@gag.com>
Mon, 15 Mar 2010 22:07:54 +0000 (16:07 -0600)
committerBdale Garbee <bdale@gag.com>
Mon, 15 Mar 2010 22:07:54 +0000 (16:07 -0600)
13 files changed:
Makefile.in
cpm.5.in
cpmls.c
debian/changelog [new file with mode: 0644]
debian/compat [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/dirs [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/gbp.conf [new file with mode: 0644]
debian/rules [new file with mode: 0755]
fsck.cpm.1.in
fsed.cpm.1.in

index 53059a07067ef76a5c225a77438357fa38e01eed..134f021f1da364dc8c099e9d4a2355d762b048a1 100644 (file)
@@ -88,7 +88,7 @@ install:      all
                $(INSTALL) -s -m 755 mkfs.cpm $(BINDIR)/mkfs.cpm
                $(INSTALL) -s -m 755 fsck.cpm $(BINDIR)/fsck.cpm
                [ $(FSED_CPM) != '' ] && $(INSTALL) -s -m 755 fsed.cpm $(BINDIR)/fsed.cpm
-               $(INSTALL_DATA) diskdefs @datarootdir@/diskdefs
+               $(INSTALL_DATA) diskdefs $(datarootdir)/diskdefs
                $(INSTALL_DATA) cpmls.1 $(MANDIR)/man1/cpmls.1
                $(INSTALL_DATA) cpmcp.1 $(MANDIR)/man1/cpmcp.1
                $(INSTALL_DATA) cpmrm.1 $(MANDIR)/man1/cpmrm.1
index 89371f6c0892fdcffd15c8aab45dcc52eb3aafbd..5e559c71e234d13ae205df7b13028ca195e54dd6 100644 (file)
--- a/cpm.5.in
+++ b/cpm.5.in
@@ -88,7 +88,7 @@ meaning:
 .sp
 F0: requires set wheel byte (Backgrounder II)
 .br
-F1: public file (P2DOS, ZSDOS), forground-only command (Backgrounder II)
+F1: public file (P2DOS, ZSDOS), foreground-only command (Backgrounder II)
 .br
 F2: date stamp (ZSDOS), background-only commands (Backgrounder II)
 .br
@@ -138,7 +138,7 @@ Bc stores the number of bytes in the last used record.  The value 0 means
 Al is interpreted as 16 byte-values, otherwise as 8 double-byte-values.
 A block pointer of 0 marks a hole in the file.  If a hole
 covers the range of a full extent, the extent will not be allocated.  In particular,
-the first extent of a file does not neccessarily have extent number 0.
+the first extent of a file does not necessarily have extent number 0.
 A file may not share blocks with other files, as its blocks would be freed
 if the other files is erased without a following disk system reset.  CP/M returns
 EOF when it reaches a hole, whereas UNIX returns zero-value bytes, which makes
diff --git a/cpmls.c b/cpmls.c
index 983817a0bf033de357b04d4bf7ca199974f9e943..1db4fba2748f6207f14e65893366bb326cbff5db 100644 (file)
--- a/cpmls.c
+++ b/cpmls.c
@@ -360,7 +360,11 @@ int main(int argc, char *argv[])
 
   if (usage)
   {
+#if HAVE_LIBDSK_H
     fprintf(stderr,"Usage: %s [-f format] [-T libdsk-type] [-d|-D|-F|-A|[-l][-c][-i]] image [file ...]\n",cmd);
+#else
+    fprintf(stderr,"Usage: %s [-f format] [-d|-D|-F|-A|[-l][-c][-i]] image [file ...]\n",cmd);
+#endif
     exit(1);
   }
   /*}}}*/
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..78e03ff
--- /dev/null
@@ -0,0 +1,70 @@
+cpmtools (2.10-2) unstable; urgency=low
+
+  * elide '-T libdsk-type' from executable usage messages, closes: #554342
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 03 Nov 2009 21:25:26 -0700
+
+cpmtools (2.10-1) unstable; urgency=low
+
+  * new upstream version
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 08 Sep 2009 12:52:46 -0600
+
+cpmtools (2.7-1) unstable; urgency=low
+
+  * new upstream version
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 05 Jun 2008 16:47:46 -0600
+
+cpmtools (2.5-1) unstable; urgency=low
+
+  * new upstream version, closes: #345395
+  * freshen policy and debhelper version
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 30 Dec 2005 21:20:27 -0700
+
+cpmtools (2.4-3) unstable; urgency=low
+
+  * patch from A Costa for fsck man page typos, closes: #327918
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 28 Sep 2005 00:53:52 -0600
+
+cpmtools (2.4-2) unstable; urgency=low
+
+  * accept patches from A Costa for man page typos, closes: #305635, #305636
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 30 Apr 2005 00:08:30 -0600
+
+cpmtools (2.4-1) unstable; urgency=low
+
+  * new upstream version, closes: #275979
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 11 Oct 2004 10:58:22 -0600
+
+cpmtools (2.1-2) unstable; urgency=low
+
+  * fix thinko in rules file handling of autotools-dev support, closes: #241585
+
+ -- Bdale Garbee <bdale@gag.com>  Thu,  1 Apr 2004 21:41:39 -0700
+
+cpmtools (2.1-1) unstable; urgency=low
+
+  * new upstream version, closes: #239681
+  * deliver cpm.5 manpage in binary package, closes: #239680
+  * add autotools-dev as a build dep to keep config.* fresh
+  * move diskdefs into /etc/cpmtools as a conffile, closes: #239677
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 26 Mar 2004 11:48:01 -0700
+
+cpmtools (2.0-2) unstable; urgency=low
+
+  * add build-depend on libncurses-dev so that fsed builds, closes: #129679
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 18 Jan 2002 11:50:16 -0700
+
+cpmtools (2.0-1) unstable; urgency=low
+
+  * Initial Release.
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 15 Jan 2002 02:23:43 -0700
+
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..7ed6ff8
--- /dev/null
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..29aff2b
--- /dev/null
@@ -0,0 +1,15 @@
+Source: cpmtools
+Section: otherosfs
+Priority: optional
+Maintainer: Bdale Garbee <bdale@gag.com>
+Build-Depends: debhelper (>> 5), libncurses-dev, autotools-dev
+Standards-Version: 3.8.3
+
+Package: cpmtools
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Tools to access CP/M file systems
+ This package allows to access CP/M file systems similar to the well-known 
+ mtools package, which accesses MSDOS file systems.
+ .
+ All CP/M file system features are supported.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..6a4f224
--- /dev/null
@@ -0,0 +1,26 @@
+This package was debianized by Bdale Garbee <bdale@gag.com> on
+Tue, 15 Jan 2002 02:23:43 -0700.
+
+It was downloaded from http://www.moria.de/~michael/cpmtools/
+
+Upstream Author: Michael Haardt <michael@moria.de>
+
+Copyright:
+
+  Copyright 1997-2007 Michael Haardt <michael@moria.de>
+
+  The Windows port is copyright 2000, 2001 John Elliott
+
+  The getopt.[ch] and getopt1.c files are
+    Copyright (C) 1989,90,91,92,93,94,96,97,98 Free Software Foundation, Inc.
+
+  The install.sh file is Copyright (C) 1994 X Consortium
+
+This program is free software; you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation; either version 3 of the License, or
+(at your option) any later version.
+
+On Debian GNU/Linux systems, the complete text of the GNU General Public 
+License can be found in the `/usr/share/common-licenses' directory.
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644 (file)
index 0000000..bb4a396
--- /dev/null
@@ -0,0 +1,4 @@
+etc/cpmtools
+usr/bin
+usr/share/man/man1
+usr/share/man/man5
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..50bd824
--- /dev/null
@@ -0,0 +1,2 @@
+NEWS
+README
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644 (file)
index 0000000..f090a6c
--- /dev/null
@@ -0,0 +1,46 @@
+# Configuration file for git-buildpackage and friends
+
+[DEFAULT]
+# the default build command:
+#builder = debuild -i\.git/ -I.git
+# the default clean command:
+#cleaner = debuild clean
+# the default branch for upstream sources:
+upstream-branch = upstream
+# the default branch for the debian patch:
+debian-branch = master
+# the default tag formats used:
+#upstream-tag = upstream/%(version)s
+#debian-tag = debian/%(version)s
+# use pristine-tar:
+pristine-tar = True
+
+# Options only affecting git-buildpackage
+[git-buildpackage]
+#upstream-branch = dfsgclean
+# uncomment this to automatically GPG sign tags
+#sign-tags = True
+# keyid to GPG sign tags with
+#keyid = 0xdeadbeef
+# push to a remote repository after a successful tag: 
+#posttag = git-push git.example.com
+# use this for more svn-buildpackage like behaviour:
+export-dir = ../build-area/cpmtools/
+#tarball-dir = ../tarballs/
+
+# Options only affecting git-import-orig
+[git-import-orig]
+#upstream-branch = newupstream
+#debian-branch = dfsgclean
+#filter = .svn
+
+# Options only affecting git-import-dsc
+[git-import-dsc]
+#upstream-branch = svn-upstream
+#filter = [ 'CVS', '.cvsignore' ]
+
+# Options only affecting git-dch
+[git-dch]
+#git-log = --no-merges
+#snapshot-number = snapshot + 1
+
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..31d753c
--- /dev/null
@@ -0,0 +1,62 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       cp /usr/share/misc/config.sub config.sub
+       cp /usr/share/misc/config.guess config.guess
+       ./configure --prefix=/usr --mandir=\$${prefix}/share/man \
+               --datarootdir=/etc/cpmtools
+       touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp 
+       dh_testdir
+       $(MAKE)
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+       [ ! -f Makefile ] || $(MAKE) distclean
+       dh_clean
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs
+       $(MAKE) install prefix=$(CURDIR)/debian/cpmtools/usr \
+               datarootdir=$(CURDIR)/debian/cpmtools/etc/cpmtools
+
+# Build architecture-independent files here.
+binary-indep: build install
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installexamples
+       dh_installmenu
+       dh_installcron
+       dh_installman
+       dh_installinfo
+       dh_installchangelogs 
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
index 36b4dcc1d01aa250f8cb702ea19467a483b94173..e31f1eaeeaf6a499704d0bbf4efe644a0733971d 100644 (file)
@@ -1,5 +1,5 @@
 .TH FSCK.CPM 1 "@UPDATED@" "CP/M tools" "User commands"
-.SH NAME ..\"{{{roff}}}\"{{{
+.SH NAME \"{{{roff}}}\"{{{
 fsck.cpm \- check a CP/M file system
 .\"}}}
 .SH SYNOPSIS .\"{{{
@@ -38,10 +38,11 @@ Any errors are indicated by exit code 1.
 @DATADIR@/diskdefs     CP/M disk format definitions
 .\"}}}
 .SH DIAGNOSTICS .\"{{{
-.IP "\fIimage\fP: \fIused\fP/\fItotal\fP files (\fIn\fP.\fIn\fP% non-contiguos), \fIused\fP/\fItotal\fP blocks"
+.IP "\fIimage\fP: \fIused\fP/\fItotal\fP files (\fIn\fP.\fIn\fP% 
+non-contiguous), \fIused\fP/\fItotal\fP blocks"
 No inconsistencies could be found.  The number of used files actually
 is the number of used extents.  Since a file may use more than
-one extent, this may be greather than the actual number of files, but a
+one extent, this may be greater than the actual number of files, but a
 correct measure would not reflect how many files could still be created
 at most.  A file is considered fragmented, if sequential data blocks
 pointed to by the same extent do not have sequential block numbers.
index 4c91f97161cf0004dc1d5be799f9cf600c337297..c87a39df91c9aa0a00670ae01ac65f5cfdb25894 100644 (file)
@@ -1,5 +1,5 @@
 .TH FSED.CPM 1 "@UPDATED@" "CP/M tools" "User commands"
-.SH NAME ..\"{{{roff}}}\"{{{
+.SH NAME \"{{{roff}}}\"{{{
 fsed.cpm \- edit a CP/M file system
 .\"}}}
 .SH SYNOPSIS .\"{{{