Imported Debian patch 2.1-1 debian/2.1-1
authorBdale Garbee <bdale@gag.com>
Fri, 26 Mar 2004 18:48:01 +0000 (11:48 -0700)
committerBdale Garbee <bdale@gag.com>
Tue, 20 May 2008 04:56:22 +0000 (22:56 -0600)
Makefile.in
debian/changelog [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/dirs [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/rules [new file with mode: 0755]

index 6894e206801bb90388291accfe7ff928b0feb401..f48459356006d7ec86561bfc4662e40f224e4e45 100644 (file)
@@ -85,7 +85,7 @@ install:      all
                $(INSTALL) -s -m 755 mkfs.cpm $(BINDIR)/mkfs.cpm
                $(INSTALL) -s -m 755 fsck.cpm $(BINDIR)/fsck.cpm
                $(INSTALL) -s -m 755 fsed.cpm $(BINDIR)/fsed.cpm
-               $(INSTALL_DATA) diskdefs @datadir@/diskdefs
+               $(INSTALL_DATA) diskdefs $(prefix)/..@datadir@/diskdefs
                $(INSTALL_DATA) cpmls.1 $(MANDIR)/man1/cpmls.1
                $(INSTALL_DATA) cpmcp.1 $(MANDIR)/man1/cpmcp.1
                $(INSTALL_DATA) cpmrm.1 $(MANDIR)/man1/cpmrm.1
@@ -94,6 +94,7 @@ install:      all
                $(INSTALL_DATA) mkfs.cpm.1 $(MANDIR)/man1/mkfs.cpm.1
                $(INSTALL_DATA) fsck.cpm.1 $(MANDIR)/man1/fsck.cpm.1
                $(INSTALL_DATA) fsed.cpm.1 $(MANDIR)/man1/fsed.cpm.1
+               $(INSTALL_DATA) cpm.5 $(MANDIR)/man5/cpm.5
 
 clean:
                rm -f *$(OBJEXT) *.1 *.5
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..71a1505
--- /dev/null
@@ -0,0 +1,21 @@
+cpmtools (2.1-1) unstable; urgency=low
+
+  * new upstream version, closes: #239681
+  * deliver cpm.5 manpage in binary package, closes: #239680
+  * add autotools-dev as a build dep to keep config.* fresh
+  * move diskdefs into /etc/cpmtools as a conffile, closes: #239677
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 26 Mar 2004 11:48:01 -0700
+
+cpmtools (2.0-2) unstable; urgency=low
+
+  * add build-depend on libncurses-dev so that fsed builds, closes: #129679
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 18 Jan 2002 11:50:16 -0700
+
+cpmtools (2.0-1) unstable; urgency=low
+
+  * Initial Release.
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 15 Jan 2002 02:23:43 -0700
+
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..be2380e
--- /dev/null
@@ -0,0 +1,15 @@
+Source: cpmtools
+Section: otherosfs
+Priority: optional
+Maintainer: Bdale Garbee <bdale@gag.com>
+Build-Depends: debhelper (>> 3.0.0), libncurses-dev, autotools-dev
+Standards-Version: 3.6.1.0
+
+Package: cpmtools
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Tools to access CP/M file systems
+ This package allows to access CP/M file systems similar to the well-known 
+ mtools package, which accesses MSDOS file systems.
+ .
+ All CP/M file system features are supported.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..1a780ce
--- /dev/null
@@ -0,0 +1,23 @@
+This package was debianized by Bdale Garbee <bdale@gag.com> on
+Tue, 15 Jan 2002 02:23:43 -0700.
+
+It was downloaded from http://www.moria.de/~michael/cpmtools/
+
+Upstream Author: Michael Haardt <michael@moria.de>
+
+Copyright:
+
+  Copyright 1997, 1998, 1999, 2000, 2001 Michael Haardt <michael@moria.de>
+
+  The Windows port is copyright 2000, 2001 John Elliott
+
+  The getopt.[ch] and getopt1.c files are
+    Copyright (C) 1989,90,91,92,93,94,96,97,98 Free Software Foundation, Inc.
+
+This program is free software; you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation; version 2 dated June, 1991.
+
+On Debian GNU/Linux systems, the complete text of the GNU General Public 
+License can be found in the `/usr/share/common-licenses' directory.
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644 (file)
index 0000000..bb4a396
--- /dev/null
@@ -0,0 +1,4 @@
+etc/cpmtools
+usr/bin
+usr/share/man/man1
+usr/share/man/man5
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..50bd824
--- /dev/null
@@ -0,0 +1,2 @@
+NEWS
+README
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..b751729
--- /dev/null
@@ -0,0 +1,68 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatability version to use.
+export DH_COMPAT=3
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       ./configure --prefix=/usr --mandir=\$${prefix}/share/man \
+               --datadir=/etc/cpmtools
+       touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp 
+       dh_testdir
+       $(MAKE)
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+       -$(MAKE) distclean
+
+       -test -r /usr/share/misc/config.sub && \
+               cp -f /usr/share/misc/config.sub config/config.sub
+       -test -r /usr/share/misc/config.guess && \
+               cp -f /usr/share/misc/config.guess config/config.guess
+
+       dh_clean
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs
+       $(MAKE) install prefix=$(CURDIR)/debian/cpmtools/usr 
+
+# Build architecture-independent files here.
+binary-indep: build install
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installexamples
+       dh_installmenu
+       dh_installcron
+       dh_installman
+       dh_installinfo
+       dh_installchangelogs 
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure