change the way config.sub/guess are handled to work better in pristine chroot
authorBdale Garbee <bdale@gag.com>
Tue, 8 Sep 2009 18:37:04 +0000 (12:37 -0600)
committerBdale Garbee <bdale@gag.com>
Tue, 8 Sep 2009 18:37:04 +0000 (12:37 -0600)
build environments

debian/changelog
debian/rules

index 62610bbbd004762b476d0efde0b1f3de47d259d4..2ce5fda3aae5ddf19ea839b8b96ebbd37cc437f2 100644 (file)
@@ -1,3 +1,9 @@
+cpmtools (2.10-1) UNRELEASED; urgency=low
+
+  * new upstream version
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 08 Sep 2009 12:34:09 -0600
+
 cpmtools (2.7-1) unstable; urgency=low
 
   * new upstream version
index 43f57a669a87dc3d84b4c8ff3561b05a303d3f8a..31d753cf39b07801bc330c95c04fa93f9e4ef213 100755 (executable)
@@ -6,6 +6,8 @@
 configure: configure-stamp
 configure-stamp:
        dh_testdir
+       cp /usr/share/misc/config.sub config.sub
+       cp /usr/share/misc/config.guess config.guess
        ./configure --prefix=/usr --mandir=\$${prefix}/share/man \
                --datarootdir=/etc/cpmtools
        touch configure-stamp
@@ -22,12 +24,6 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
        [ ! -f Makefile ] || $(MAKE) distclean
-
-       -test -r /usr/share/misc/config.sub && \
-               cp -f /usr/share/misc/config.sub config.sub
-       -test -r /usr/share/misc/config.guess && \
-               cp -f /usr/share/misc/config.guess config.guess
-
        dh_clean
 
 install: build