fold in Debian packaging goo
authorBdale Garbee <bdale@gag.com>
Sat, 3 May 2008 05:19:47 +0000 (23:19 -0600)
committerBdale Garbee <bdale@gag.com>
Sat, 3 May 2008 05:19:47 +0000 (23:19 -0600)
debian/changelog [new file with mode: 0644]
debian/compat [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/dirs [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/rules [new file with mode: 0755]

diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..f36c3eb
--- /dev/null
@@ -0,0 +1,6 @@
+as31 (2.3.1-1) unstable; urgency=low
+
+  * Fresh (re-)packaging for Debian
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 02 May 2008 23:08:35 -0600
+
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..7ed6ff8
--- /dev/null
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..ce782e1
--- /dev/null
@@ -0,0 +1,12 @@
+Source: as31
+Section: devel
+Priority: optional
+Maintainer: Bdale Garbee <bdale@gag.com>
+Build-Depends: debhelper (>= 5)
+Standards-Version: 3.7.3
+
+Package: as31
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Intel 8031/8051 assembler
+ This is a fast, simple, easy to use Intel 8031/8051 assembler.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..59e6850
--- /dev/null
@@ -0,0 +1,25 @@
+This package was debianized by Bdale Garbee <bdale@gag.com> on
+Wed, 30 Apr 2008 20:18:40 -0700.
+
+It was downloaded from 
+    <http://wiki.erazor-zone.de/doku.php?id=wiki:projects:linux:as31>
+
+Upstream Authors: 
+    Ken Stauffer <ken@stauffercom.com>
+    Paul Stoffregen <paul@pjrc.com>
+    Alexander 'E-Razor' Krause <admin@erazor-zone.de>
+
+Copyright: 
+
+    Copyright (C) 1989 by Ken Stauffer
+
+License:
+
+    AS31 is Free Software, provided under the BSD license.
+
+    AS31 is distributed in the hope that it will be useful, but without any 
+    warranty; without even the implied warranty of merchantability or fitness 
+    for a particular purpose.
+
+The Debian packaging is (C) 2008, Bdale Garbee <bdale@gag.com> and
+is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644 (file)
index 0000000..e772481
--- /dev/null
@@ -0,0 +1 @@
+usr/bin
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..6f83607
--- /dev/null
@@ -0,0 +1,3 @@
+AUTHORS
+NEWS
+README
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..9e498b0
--- /dev/null
@@ -0,0 +1,54 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       ./configure --prefix=/usr
+       touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp 
+       dh_testdir
+       $(MAKE)
+       touch $@
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+       $(MAKE) clean
+       dh_clean 
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k 
+       dh_installdirs
+       $(MAKE) DESTDIR=$(CURDIR)/debian/as31 install
+
+# Build architecture-independent files here.
+binary-indep: build install
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs ChangeLog
+       dh_installdocs
+       dh_installman as31/as31.1
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure