fix FTCBFS master debian/2.3.1-9
authorBdale Garbee <bdale@gag.com>
Thu, 18 Nov 2021 20:29:05 +0000 (13:29 -0700)
committerBdale Garbee <bdale@gag.com>
Thu, 18 Nov 2021 20:29:05 +0000 (13:29 -0700)
debian/changelog
debian/rules

index ba7704eddb7d0beae34cfdb53068fffba2ab421b..0ecdc49ef29725cab5b91323bf0f7b3680932eb7 100644 (file)
@@ -1,3 +1,10 @@
+as31 (2.3.1-9) unstable; urgency=medium
+
+  * Fix from Helmut Grohne for FTCBFS: Pass --build/--host to configure,
+    closes: #999885
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 18 Nov 2021 13:28:44 -0700
+
 as31 (2.3.1-8) unstable; urgency=medium
 
   * note in debian/copyright that we assume the 3-clause BSD variant,
index 9d919b4ae9b0175f2fc5a6b533198a4cb8f5ac13..932092a3617d902c3da17ca5ea849d11b993a179 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 
+include /usr/share/dpkg/architecture.mk
+
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
@@ -7,7 +9,7 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        chmod a+x ./configure ./missing
-       ./configure --prefix=/usr --mandir=/usr/share/man
+       ./configure --prefix=/usr --mandir=/usr/share/man --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
        touch configure-stamp
 
 build: build-arch build-indep