fix a few other bugs as long as we're going to make an upload debian/2.6.1p1-2
authorBdale Garbee <bdale@gag.com>
Fri, 16 Oct 2009 08:10:55 +0000 (02:10 -0600)
committerBdale Garbee <bdale@gag.com>
Fri, 16 Oct 2009 08:10:55 +0000 (02:10 -0600)
debian/amanda-server.README.Debian
debian/changelog
debian/po/fi.po [new file with mode: 0644]
server-src/diskfile.c

index 809b966f89199517ea58d27b88d05b357f995c60..6526640ff29d4ea2cf397ace101e7891ef7a9e33 100644 (file)
@@ -124,3 +124,26 @@ info on this issue see:
 
        http://forums.zmanda.com/archive/index.php/t-591.html
 
+- - - - -
+
+If you see things like this in dmesg:
+
+    INFO: task ammt:9839 blocked for more than 120 seconds.
+    "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
+
+This information from Marc Schaefer may relevant:
+
+> AFAIK it's because mtio operations are done in D state (uninterruptible
+> sleep).
+> 
+> And except for mtio operations which may last more than two minutes,
+> nothing in the usual kernel operation will last that long.
+> 
+> Solutions:
+>      - either fix mtio to be interruptible (which may well cause problems
+>        because e.g. SCSI reselection might happen later)
+>      - use the proposed work-around
+>      - ignore those messages in your logcheck.
+
+
+
index 6877ce1780064fbd3aa06f30d6f66c008a1f3216..fa43b4cb6206796f6828d19ae8fa80e0fd7661b5 100644 (file)
@@ -1,8 +1,13 @@
-amanda (1:2.6.1p1-2) UNRELEASED; urgency=low
+amanda (1:2.6.1p1-2) unstable; urgency=low
 
   * calcsize needs to be setuid, closes: #551156
+  * patch from upstream to fix init of xml_app.result in diskfile.c, 
+    closes: #550098
+  * add note to server package README.Debian regarding mtio operations that
+    take too long putting noise in dmesg, closes: #506397
+  * merge Finnish translation of the debconf templates, closes: #535214
 
- -- Bdale Garbee <bdale@gag.com>  Fri, 16 Oct 2009 01:41:44 -0600
+ -- Bdale Garbee <bdale@gag.com>  Fri, 16 Oct 2009 02:10:52 -0600
 
 amanda (1:2.6.1p1-1) unstable; urgency=low
 
diff --git a/debian/po/fi.po b/debian/po/fi.po
new file mode 100644 (file)
index 0000000..3219c79
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright (C) 2009
+# This file is distributed under the same license as the amanda package.
+#
+# Esko Arajärvi <edu@iki.fi>, 2009.
+msgid ""
+msgstr ""
+"Project-Id-Version: amanda\n"
+"Report-Msgid-Bugs-To: amanda@packages.debian.org\n"
+"POT-Creation-Date: 2008-04-16 01:13-0600\n"
+"PO-Revision-Date: 2009-06-30 22:11+0300\n"
+"Last-Translator: Esko Arajärvi <edu@iki.fi>\n"
+"Language-Team: Finnish <debian-l10n-finnish@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: Lokalize 0.3\n"
+"Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
+#. Type: error
+#. Description
+#: ../templates:1001
+msgid "Please merge /var/lib/amandates and /var/lib/amanda/amandates"
+msgstr "Yhdistä /var/lib/amandates ja /var/lib/amanda/amandates"
+
+#. Type: error
+#. Description
+#: ../templates:1001
+msgid ""
+"You have both /var/lib/amandates and /var/lib/amanda/amandates. Please "
+"review the files, and merge the contents you care about to the /var/lib/"
+"amanda/amandates location, and remove the old file /var/lib/amandates."
+msgstr ""
+"Järjestelmässä on sekä tiedosto /var/lib/amandates että tiedosto "
+"/var/lib/amanda/amandates. Tarkasta molemmat tiedostot ja yhdistä "
+"tarvittava sisältö tiedostoon /var/lib/amanda/amandates. Poista tämän "
+"jälkeen vanha tiedosto /var/lib/amandates."
+
index 5c3662ef558227b7546fa778c6d21c9ddc67f5e1..f25b50be82534c0bc366c3848c0ec0db57f6aefe 100644 (file)
@@ -1784,7 +1784,6 @@ xml_scripts(
     xml_app_t   xml_app;
 
     xml_app.features = their_features;
-    xml_app.result   = stralloc("");
 
     xml_scr = stralloc("");
     for (pp_scriptlist1=pp_scriptlist; pp_scriptlist1 != NULL;
@@ -1881,6 +1880,7 @@ xml_scripts(
                                  "</execute_on>\n", NULL);
        amfree(eo_str);
        proplist = pp_script_get_property(pp_script);
+        xml_app.result   = stralloc("");
        g_hash_table_foreach(proplist, xml_property, &xml_app);
        xml_scr = vstrextend(&xml_scr, xml_scr1, xml_app.result, "  </script>\n", NULL);
        amfree(b64plugin);