add make check to the rules file
authorBdale Garbee <bdale@gag.com>
Mon, 14 Jun 2010 21:36:56 +0000 (15:36 -0600)
committerBdale Garbee <bdale@gag.com>
Mon, 14 Jun 2010 21:36:56 +0000 (15:36 -0600)
debian/changelog
debian/rules

index b3be9ef82cb41f461d63b5a70de437320c3fa285..8785d2e2456f21116094d3eb0cc4a5b8f00a4bda 100644 (file)
@@ -1,6 +1,7 @@
 amanda (1:3.1.0-1) UNRELEASED; urgency=low
 
   * new upstream version
+  * turn on regression tests
 
  -- Bdale Garbee <bdale@gag.com>  Mon, 14 Jun 2010 13:46:03 -0600
 
index 3673f1a6eb5eb6b79e9eec800ae665cd2c6e9900..a26fcc19bcbfd7166ebe54e975130e5c9170e01a 100755 (executable)
@@ -50,9 +50,14 @@ configure-stamp:
 build: build-stamp 
 build-stamp: configure-stamp
        dh_testdir
-       MAILER=/usr/bin/mail make CFLAGS="-O2 -g -Wall \
+       MAILER=/usr/bin/mail $(MAKE) CFLAGS="-O2 -g -Wall \
                -DAMANDATES_FILE='\"/var/lib/amanda/amandates\"' \
                -DIGNORE_TAR_ERRORS "
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+       $(MAKE) check
+endif
+endif
        touch build-stamp
 
 clean: