many more lintian-related warnings addressed
authorBdale Garbee <bdale@gag.com>
Thu, 20 Aug 2009 07:03:25 +0000 (01:03 -0600)
committerBdale Garbee <bdale@gag.com>
Thu, 20 Aug 2009 07:03:25 +0000 (01:03 -0600)
debian/amanda-client.postinst
debian/amanda-client.prerm
debian/amanda-server.postinst
debian/amanda-server.prerm
debian/config
debian/control
debian/postinst
debian/preinst
debian/rules

index 40a0b80d127587988ec7743fc05030c51e3ada75..f8d7f1fb92654a510d174dac850b17b2129af1a5 100644 (file)
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/sh -e
 
 update-inetd --group "OTHER" --add "amanda dgram udp wait backup /usr/sbin/tcpd /usr/lib/amanda/amandad -auth=bsd amdump amindexd amidxtaped"
 
index b86df5c1bf237519b09877e37bf6ce5b8e895aba..3645d0f3a24c4eff41b2774fb95b9b73cdf3cc65 100644 (file)
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/sh -e
 
 update-inetd --remove "amanda "
 
index 0b760829cc173a13fb65edcb1b4ec0fb4d956e1e..45d877229155bbd17db2524cc2f027f074483152 100644 (file)
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/sh -e
 
 update-inetd --group "OTHER" --add "amandaidx stream tcp nowait backup /usr/sbin/tcpd /usr/lib/amanda/amindexd amindexd -auth=bsd amdump amindexd amidxtaped"
 update-inetd --group "OTHER" --add "amidxtape stream tcp nowait backup /usr/sbin/tcpd /usr/lib/amanda/amidxtaped amidxtaped -auth=bsd amdump amindexd amidxtaped"
index 2bcb874a7622fce939c64bae69491727c7107409..428802655d01fb56b6f5f006edd6b1c924188a16 100644 (file)
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/sh -e
 
 update-inetd --remove amandaidx
 update-inetd --remove amidxtape
index 6917623d056db047f0c73c724cf552c3a63e400f..5b622bbeb507d62db556ed5d3fdc6752b3972499 100644 (file)
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/sh -e
 
 . /usr/share/debconf/confmodule
 
index a172aa9a39c359ccf150c405c721871d286602a4..87cdff5e8207bdbe5e72237ab2b758557efe92ec 100644 (file)
@@ -9,7 +9,7 @@ Standards-Version: 3.8.3
 
 Package: amanda-common
 Architecture: any
-Depends: ${shlibs:Depends}, update-inetd, tar (>=1.12), perl5, mailx, debconf | debconf-2.0, adduser, openbsd-inetd | inet-superserver
+Depends: ${misc:Depends}, ${shlibs:Depends}, update-inetd, tar (>=1.12), perl5, mailx, debconf | debconf-2.0, adduser, openbsd-inetd | inet-superserver
 Suggests: amanda-server (= ${binary:Version}) | amanda-client (= ${binary:Version})
 Conflicts: amanda
 Replaces: amanda, amanda-client
@@ -19,7 +19,7 @@ Description: Advanced Maryland Automatic Network Disk Archiver (Libs)
 
 Package: amanda-server
 Architecture: any
-Depends: ${shlibs:Depends}, amanda-common (= ${binary:Version}), mailx
+Depends: ${misc:Depends}, ${shlibs:Depends}, amanda-common (= ${binary:Version}), mailx
 Suggests: perl5, gnuplot, amanda-client (= ${binary:Version}), cpio | mt-st
 Conflicts: amanda, amanda-common (<< 1:2.5.2p1-3)
 Replaces: amanda-common (<< 1:2.5.2p1-3)
@@ -67,7 +67,7 @@ Description: Advanced Maryland Automatic Network Disk Archiver (Server)
 
 Package: amanda-client
 Architecture: any
-Depends: ${shlibs:Depends}, amanda-common (= ${binary:Version})
+Depends: ${misc:Depends}, ${shlibs:Depends}, amanda-common (= ${binary:Version})
 Suggests: gnuplot, dump, smbclient
 Conflicts: amanda, amanda-common (<< 1:2.5.2p1-3)
 Replaces: amanda-common (<< 1:2.5.2p1-3)
index dcba6bf7396571f27e6a2aeb014a5eecb287528d..be6a549195592ebc5819a34f3ef788f07b15c8cd 100644 (file)
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/sh -e
 
 . /usr/share/debconf/confmodule
 
index b7a735b96a29e5fc45813647a50d496b3e37edba..e541f24c3b04c00c895324d2f6e7109568b4c652 100644 (file)
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/sh -e
 
 # if a .amandahosts exists and is not a symlink, move it to /etc
 if [ ! -L ~backup/.amandahosts ]
index 764713c38507ca9ba1cf3b014124b416594787d4..c9c34fcda76bdbbe4ea00c30b2837b495cc2b4e9 100755 (executable)
@@ -25,6 +25,7 @@ configure-stamp:
                --bindir=/usr/sbin \
                --libexecdir=/usr/lib/amanda \
                --without-amlibexecdir \
+               --with-amperldir=/usr/share/perl
                --sysconfdir=/etc \
                --sharedstatedir=/var/lib \
                --localstatedir=/var/lib \